MAC addresses visible on internet

I’m using a Peplink Balance One core with firmware 8.1.1. My ISP just informed me that they are seeing not only the MAC addresses of my WAN ports of my Peplink router but also the MAC addresses of the 12 other devices I have connected to my router. They had terminated my service as they said some of their other customers were receiving DHCP requests from my router. So I upgraded the firmware and factory reset it. I set up my two WAN connections (one with static IP and one with PPPoE) both with “NAT routing mode”, changed admin password and internet is working fine but ISP tells me they can still see the MAC addresses of my devices connected to the Peplink.

How do I stop this from happening?

Shane

1 Like

@Shaner ,

May i know is this a new deployment ? Would you please open a ticket for us to review the setup ?

https://ticket.peplink.com/ticket/new/public

Possible please include the physical network connection diagram in the ticket to help support team when checking the issue.

This setup has been in use for almost three years. I will compile the requested information and open a ticket.

Thanks,
Shane

Who is the ISP?

@Shaner

Can you share the ticket number ?

Thank you

This sounds so improbable that I would question the ISP.

Your router can log every packet that leaves the WAN port. I suggest connecting just one WAN connection, then turning on that log using the support.cgi page. And ask the ISP exactly what they are seeing. That is, what types of packets do they see with your private MAC addresses - and verify these are really the MACs of your devices.

Which begs the question: how the heck can an ISP know what the MAC addresses of your devices are? How do they know the rogue MAC addresses s do’nt belong to another customer of theirs? Very strange indeed.

Ticket 21020268

It is a wireless ISP and I guess they are able to determine what is passing along the wireless connection. They were able to provide me with a list of MAC addresses and I verified they were from my network.

Wow. I can not even guess. Please let us know what it turns out to be.

1 Like

Thank you. Support team will follow with you via support ticket.

@Shaner ,

I just replied the ticket.

Found that you have enable IPv6 passthrough for the Balance One Core, potentially this is the issue why ISP see the LAN MAC addresses.

1 Like
  Yes, after disabling IPv6 passthrough the ISP no longer sees any LAN connected MAC addresses.  Thanks for your assistance.

Where is the IPv6 setting? Specifically on the BR1 MK2? Thanks.

@mystery, the IPv6 option is available on the higher-end models, eg. Transit (excluded the Mini), HD, X, and Balance series, which you will see the setting like this, under Network > WAN.

You can also find it from the product website, under the Deep Dive section, eg. 400Mbps 4G LTE Router for Public Transportation MAX Transit- Peplink

Thanks to everyone for figuring this out.

@Michael234 : @WeiMing and @sitloongs are stars. :dizzy:
:blush:

1 Like