LTE WAN IP topology through open APN not working

Hi all,

I am trying to setup a Peplink Max Br1 Mini on LTE using an open APN from our carrier.

Normal behaviour in a carrier NAT situation is receiving a shared IP on WAN and private IPS on gateway and DHCP. Because we want to do port forwarding we need a public ip bonded to our Peplink WAN.
The issue is that even when setting up this “open” APN we keep receiving the shared IP on our WAN port. When I try the sim in my android we get a working IP for port forwarding etc.


Can we do something with a static route to the gateway?
Can we force APN somewhere?

Any help, experience or how to are much appreciated!

Thank you

sounds like you need to change the APN settings from auto to custom and enter them manually so you get the right IP assignment.

Really not a fan of public IPs directly on the cellular connection though. Think about changing the topology when you can to do port forwarding in the cloud via a hosted Fusionhub. Then you can use any SIM from any provider and failover to wired and wifi WAN (if the mini is licensed for that) all without the public IP changing.

1 Like

Hi Martin, thanks for getting back to me.

Already on custom APN, just want to rule out any Peplink related issues on this as the APN works fine using a phone. I don’ t see an issue with an open APN as it is the same as using a broadband WAN with public IP.

Looking at the Fusionhub solo route as well, just seems a lot of overhead for an external connection :slight_smile:

Right now I am using Google Compute, with proper firewall settings. But both machines hang on “Starting”. When I look at the BR1 is see the VPS private IP listed first and public IP listed second.

Looking at Fusionhub I see it is looking for the which is the shared carrier grade IP, so that could be the issue.

I thought I only needed one fixed IP for this connection? How does this setup work? Now I set it up using the easy method via Incontrol.

Here is my BR1:



Thats right.

Use star topology as the VPN configuration with Fusionhub as the hub device.

I see - that wasn’t clear. We’d expect to see Carrier NAT on auto settings for APN, however all mobile networks (and MVNOs) do public IP addressing differently. Some will allocate the routable WAN IP to the router’s cellular WAN, others will assign a private IP address that has a 1:1 NAT relationship with a public IP in the network core.

1 Like

Hi Martin,

Thanks for the reply, I am now working with support since all is good but we are stuck at creating tunnels now…

I still think it is a very elaborate solution and prefer a public IP but we will give Fusionhub a shot.

I clarify, If you have an APN that provides a public IP then you can use that if you want, but you were having issues getting your APN to work.

I did make a video about APNs a while ago in case anyone is interested: