LAN port speed

Balance 20x firmware 8.1.3

I have a Windows 7 laptop that I put to sleep each night. The next day when opening the lid to wake it up, the Event log shows that the Ethernet port it is connected to has activated and the speed of the LAN port. Some days the speed is correctly 1 GB but many days the speed is only 100MB. Would running a pcap trace on the router, just before waking the laptop, show anything useful here?
Thanks in advance.
FYI: tried to create an “ethernet” tag for this item. No error message and no tag.

Pcap will not help to check the negotiated port speed. By the way, may I know how you confirm the port speed is 100Mbps? From the support.cgi page of Balance 20X?

1 Like

I would suggest two things,

First, try the tests with a short cable right near the B20X to confirm it is port incompatibility and not cable I I have found some Gig-e negotiations to be very cable dependent, even with 2m cables.

the speed is indicated in the log when link is re-established. the support.cgi information isn’t there for a B20X.

Dec 30 11:25:36Port: Port 4 (LAN Port 4) status changed (link up, speed 1 Gbps Full Duplex)
Dec 30 11:25:33Port: Port 4 (LAN Port 4) status changed (link down)

If you still get errors with a short cable, I would put a small switch between the B20X and the windows machine, sometimes chipsets just don’t negotiate the hardware layer the same way.

1 Like

Could you elaborate on that? I checked one of our B20x units, and the …/MANGA/support.cgi page with the port speed available for display was accessible on that unit:



Yes you see that there is only 1 LAN in that screen… Where there are 4 ports on the B20X.

Therefore that does not indicate what each individual switch port has negotiated, and only the log tells you that.

These devices reuse the same or similar SOC. I don’t know which one, but it is likely similar to the MT7621 SoC

Is a block diagram of how the Micro-Tik router uses that SOC, as you see there are only 2 data buss lines from the SOC to the port fabric. It looks like Peplink uses the WAN port for one of them (fixed) and then all of the other 4 LAN ports are switched in the switch module.

Therefore the LAN speed shown in the support.cgi page is likely to be some internal placeholder.

1 Like

Pcap will not help to check the negotiated port speed.

Too bad, but, interesting.

The port speed is reported in the Event log. Attached are two such messages for the same laptop.



Dug deeper. I checked the support.cgi page and it says LAN status is “Not negotiated” even though speed is set to “Auto”. Hover over the LAN Status info and it says that supported link modes are not reported. Screen shot below.

In the main router interface, Network tab → Port settings has all 4 ports with a speed of “Auto”. Screen shot below.

To quote an old cowboy movie: “what we have here, is a failure to communicate” :slight_smile:

@Michael234, I think we need to drill down further. Can you help to check the negotiated port speed from your laptop when the Event log of B20X shows it is negotiated as 100Mbps?

Laptop is Windows 7. It agrees on the 100Mbps port speed as shown below.

Ethernet Hardware: Intel 82579LM Gigabit Network Connection.
Driver is from Intel and dated January 11, 2012. Version

There are many Ethernet configuration options and I am not familiar with any of them. But looking at them, some may be of interest.

Option is ON to “allow the computer to turn off this device to save power”. So maybe when the lid is lifted and Sleep mode is ended, the router responds faster than the computer breaking the normal speed negotiation. Total guess. Will turn this option OFF.

PME is enabled (power management?)

Link speed and Duplex is set to “auto negotiation”

Energy Efficient Ethernet is “On if system is awake”. Will turn that OFF.

Gigabit master/slave mode is “Auto detect”

Interrupt Moderation is enabled

Log Link and State Event is enabled. No idea where the log is.

Reduce speed on power down is Enabled. I will disable that.

System idle power save was disabled.

There are maybe 10 other Ethernet config options.

I ran a Windows diagnostic and it generated a Windows ETL file, an event log, with its tests and results. Might this be useful?

This is weird. I made the few Ethernet config changes detailed above, then put the laptop to sleep for a few minutes and woke it up. LAN speed was GB for 3 seconds, then fell back to 100Mbps

Support.cgi page for the LAN interface has a Status of “not negotiated” and a speed of 100Mbps. Hovering the mouse over this, the popup says “support link modes not reported, supported pause frame use: NO, supported FEC modes not reported, Advertised link modes not reported and Advertised pause frame use: NO”

Erm, if the driver is seriously ~10yrs old I’d grab the last released one for Win7 direct from Intel. It may not fix the issue, but it is probably worth a shot, as who knows what low level oddness was fixed since that release!

Link below should be what you need for that chipset, either 32bit or 64bit depending on what version of Win7 you’re running:

Point taken. Will do. Thanks.