L2tp with ipsec issue with windows 10


I tried several times to connect via L2TP/IPSEC remotely to my site with windows 10 client but it works only with Macbook, Imac or Mobile phone.

It is always a problem with windows 10, I had a look with the topic on the forum and tried all of them but still not working…

I repeat it works 100% fine with mac… Any tips?

Best regards

We use L2TP from the Peplink Balance all the time. Standard Windows 10 L2TP client.

vpn type: L2TP with preshared key
type of sign in: user name and password

1 Like

I do the same but only works fine with APPLE DEVICE…

If i use a WIN 10 vpn clients, it is not connecting…

Do you have more explanation.?

In front of my one i have a BOX from Orange called LIVEBOX all the traffic is rooted to the wan 1 and the ip address of the pelink is dmz in the router any idea?

Thanks in advance.

Is it possible there is more than a single Windows machine using L2TP behind the same NAT device where you are testing from?

1 Like

Hi 2 years after! and after 50 installation with more peplinlk i still need to use an imac to sort out the vpn issue
Unfortunately i need my pc for sofwre use!!!
Pleazse pleasqe not acceptable

@pilipili this is an old thread. The solution for this has been discussed several times. I have dozens of Windows 10 users connecting via L2TP. There is a setting on the client computer that must be made. This is not unusual, some other L2TP servers require the same.

Windows Control Panel > Network and Sharing > Change Adapter Settings
Right click the VPN connection name and go to Properties
Security Tab
Under Data encryption check “allow these protocols” and make sure MS-CHAPv2 is checked.

With this your connection will work fine. There are issues with public and hotel wifi often blocking the ports used for L2TP but that is not a Peplink or client issue. For those scenarios PPP will usually work but of course is not recommended.