Known Issue : Google Maps not working on private InControl Appliance

incontrol2

#1

Hi,

We are aware of an issue which has started to occur from today - 15th August 2018. This issue relates to customers using their own InControl Appliance or Virtual Appliance. These customers see a message across the Google Maps image (which is displayed darker than normal) “For development purposes only”.

This message appears because Google changed their Google Maps API overnight. We are implementing a fix for this issue affecting ICA / ICVA in firmware 2.7.3 that will be available within the next couple of weeks. This new version will allow customers to enter their own Google Maps API.

However, customers can change to OpenMaps which is supported from firmware 2.7.1. You can make this change from Organisation Settings -> Map

Here is a > Link < for upgrade guidance and more information.

Thanks,

Steve


#2

Hello,
In the online IC2 at 2.7.3 I have exported a GPX from a Max Br1 Mini unit on FW 7.1.0 and it will import OK into Google Earth but not “Google My Maps”. GPX file is only 18KB.
Can you advise please?
Thank you.


#3

We will add Google Maps import support in later releases. As a workaround, you can open the GPX file with a text editor and add a version and a creator attribute to the gpx tag in the file header. Then Google Maps will accept it.

I.e.:
<gpx version="1.1" creator="Peplink InControl https://incontrol2.peplink.com/" xmlns="http://www.topografix.com/GPX/1/1" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.topografix.com/GPX/1/1 http://www.topografix.com/GPX/1/1/gpx.xsd">


#4

That worked. thank you.


#5

Hi Guys
We have also bene seeing an error like this on some devices.
One of two things happen;
-The maps slightly greyed out and has “for development purposes only”
-The map failed to display at all.

I’ll take screenshots next time I see it.


#6

As Steve’s post stated, it is a known issue for ICA. IC 2.7.3.1 that was released earlier today has addressed the issue.


#7

Hi @Michael
I read the original post as though it only related to “privately hosted” IC2 Appliances.
Thanks


#8

Hi,
is there a fix for ICVA now? I’ve got the same issue with 2.7.3.6.

Regards
Dennis


#9

Hi Dennis,

Yes, you can either add your Google details, as shown on the guide > Here < on pages 16 and 17 or, you can change the settings at Organisation level to use OpenStreetMap instead - it is a tick box (per Organisation, on your ICVA).

I hope this helps,

Steve