Kind of says it all. Speedfusion doesn't bond for increased bandwidth

I would be curious to know the outcome of this as well, just because I am in a similar situation but haven’t yet done the amount of testing donein this thread due to lack of time. Would love to at least be aware of the conclusion.

@Seablade, I would suggest contacting your point of purchase to get help. Our partner should able to help to rule out the issue you are facing.

Thanks.

Any updates on this?

You can all tell me if it’s better. I don’t think it’s acceptable but if Peplink would just say that Speedfusion really doesn’t work with two cellular links, I’d have less angst.

Verizon (no Speedfusion tunnel):

ATT (no Speedfusion tunnel):

Speedfusion (Choopa) Verizon and ATT bonded, ENCRYPTION OFF:

can you run speed tests using same speed test server?

Not that it matters, but…

Speedfusion in the router interface:

Speedfusion at the client (encryption off - should be 100Mbs on Max Transit per Peplink literature) :

Nuf said.

Hi Joel,

Thing we have seen so far that the underlying problem is something with carrier aggregation.
In our test as soon as we use 2 LTE links instead of LTE-A speedfusion works perfect.
(just use 1 enabled band for Verizon and 1 for AT&T should do the trick of getting LTE connections)

Could you please try this aswell? i am curious to see if providers across the big pond are causing the same “experience”.

Therefore i don’t think this problem is comming directly from the speedfusion algorithm itself, but is experiencing performance issues when using agregated connections. Which would imply 5G is going to be even worse :frowning:

Thnx!

Hello,
Both of my LTE connections are aggregated.

ATT - aggregated on Band 2 twice.
Verizon - aggregated on Band 66 twice.

LTE-A provides the fastest links for those devices that do streaming due to VPN blocking.

Yes i understand, so ATT and Verizon do not have other bands that are just for just LTE?

If I use ATT Band 12, I get 3Mps rather than 60 - 100.
If I use Verizon Band 13, I get <10Mps rather than 60 - 100.

I’ve analyzed and tried every option with the bands available and letting the router work on ATT=2 and Verizon=66 gives me, by far, the best performance. I’ll see if I can prevent from aggregating and still use these bands.

I don’t see an option to specify no aggregation.

Ok, i understand this is not a solution, but at least for me to better understand where problems start. At least we see the same kind of problem here as well.

There is none, here our providers use 2 different bands to do aggregation, band 3 and 21 for example. Turning 1 of the 2 off, makes the link switch to LTE. If that doesn’t work like that with verizon and / or ATT i wouldn’t know how to not make them aggregate. So no testing i am afraid :frowning:

If what you mention is true about not bonding well with aggregated links, it would be nice to have the option of restricting aggregation. My two cellular links are rather even in performance and if it’s just a problem that they’re aggregated, it certainly is sad. :frowning:
@TK_Liew Is there anything in the engineer’s bug lists that would indicate that link aggregation is a problem when trying to use Speedfusion bonding?
Thanks.

My testing shows that I get about 4% more bandwidth when the LTE link aggregates the same band twice. So, I would come out pretty far ahead if I took a loss on carrier aggregation BUT Speedfusion actually worked when aggregation isn’t happening.

I tried disconnecting the diversity feed from both my ATT an Verizon MIMO antennas BUT the links fail. So, this doesn’t work either.

i will do a similar test soon here in austria/europe also with the two lte modems in use (lte-a pro)

Thank you. If aggregation is truly a problem with Speedfusion, Peplink needs to address it - it’s very bad.