Issues with PepLink IPSEC VPN. Does it only supports network-to-network connection with Cisco, Juniper or Peplink devices?

Hi there,

I’ve been attempting to link a Peplink to a router/gateway that isn’t from Cisco, Juniper, or Peplink. Does Peplink exclusively work with IPsec tunnels with these specific devices? Are there any alternatives or workarounds for this? The gateway we’re aiming to connect to is located in Perimeter 81.

Thank you.

I also close IPSEC with Mikrotik, without issues.


Peplink supports IPsec, it is tested with Cisco and Juniper.
We have a lot of customer with other vendors. You have to try it.


Interesting. What configuration or settings are you using? I’ve tried multiple set ups but have not been successful.


I’ve been working on setting up an IPsec VPN tunnel from a Peplink to a Perimeter 81, but I haven’t had any luck so far. I’ve experimented with various configurations, but it always seems to get stuck at the connecting stage. I’ve checked the event logs, but I’m not seeing any relevant information there. It’s also a bit puzzling that the portal indicates it only supports IPsec connections to Cisco, Juniper, and Peplink devices.

Keeping it simple…

Ike v1 / v2

Follow a sample with Teltonika.

Thank you. I will try and replicate.

Tried similar settings but im still not successful. Could you elaborate your settings for Local ID and Remote ID?


You need to adapt this configurations for your WAN / LAN ip address.


Just wanted to drop you a quick note to say thanks for your help. I managed to sort things out on my end. Turns out, the problem wasn’t with my configs but with the WAN settings in the IPSEC configuration. Once I made the right adjustment, the tunnel came up and I was able to connect without any issues. Appreciate your support.

1 Like