Issue with Profiles


#1

Sofar I have used only one profile to connect to my WAN WiFi and had no problems.
The last few days I have been travelling and connected to multiple Access Points. For every AP I created a profile.
Back home I selected my original and oldest profile, the Surf OTG connected to the AP, configured my 3G as backup link and everything seemed OK.

Until I looked in Basic Settings --> WiFi WAN Settings --> Profile select.
The profile which is listed there is NOT the profile the OTG is connected to, but is the LAST profile I created when travelling and therefor not even close.
I selected my home profile, saved the new settings and checked the Dashboard to see that indeed my home profile was active.
Went back to: Basic Settings --> WiFi WAN Settings --> Profile select and… again that wrong profile was listed.

So I took a drastic step and deleted that last profile, went back into settings, selected and saved my home profile and logged out of the web interface.
When I logged back in, I found the one-but-last profile I created and again NOT my home profile.

IN SHORT: Whatever I do it seems that always the last created profile shows in the settings. Is this “as designed” or am I right that this is not what it is supposed to do? (NOTE: The OTG keeps on functioning well)


#2

Hi water-man,

The “Profile select” is just an easy way for user to edit particular profile. It doesn’t mean select the profile as active profile. For the OTG, it would choose the most suitable one to connect to in the profile list.

We may improve the web UI in order to show the connected profile in setup page in coming release.

Bryan


#3

Hi Bryan,

OK, I understand, but can you answer this question:
I have 2 known profiles I could connect to. The OTG selects the most suitable, but that is not the one I want selected (for whatever valid reason). The “Profile select” option gives the impression that that is exactly what I can do: select the SSID I want to connect to.
If this option does not do that, where in the UI can I make it select the SSID I want?

Thanks!


#4

Hi water-man,

Sorry for the “Profile Select” wording misleading you. If you have a preferred profile to connect to, you can check the star icon beside the profile name.

Bryan


#5

Sorry Bryan, I’ll keep nagging…:confused:

I have a preferred WiFi SSID at home, let’s call it SSID1.
Just for the hack of it I switched on Android hotspot on my phone: SSID2
To make the OTG switch from SSID1 to SSID2, I made a profile (SSID2), starred it, removed the star from SSID1 and saved it.
Then I went back to Dashboard and I saw it switch from SSID1 to SSID2.

SO FAR SO GOOD.

Then I removed the star from SSID2 and starred SSID1 and saved the settings.
Tried to switch to Dashboard, but did not get response for a couple of min’s, saw on the leds that it was busy switching.
Then dashboard come up: but still on SSID2. Looked on settings and saw that the star on SSID1 is OFF, star on SSID2 is ON (again).
In short: whatever I do, I can’t make it switch back to SSID1, neither can I permanently remove the star from SSID2.

Even if I ignore the “Select Profile” option and hand-pick SSID1 in the SSID box under it, it will do a disconnect-connect cycle, but still come back with SSID2.

My Conclusion: I AM NOT ABLE TO SWITCH BACK AND FORTH BETWEEN SSID’S ONCE THE OTG ESTABLISHES A PREFERENCE.

TO ADD COMPLEXITY: all this time I had a 3G USB stick connected to the OTG and enabled the fail-over option.
To check whether there was a relation between this enablement and the SSID selection, I disabled the fail-over function in the web interface, saved it and went to the dashboard.
OK: 3G backup was gone

First time after that switching from SSID2 to SSID1, I was succesfull. I could even switch back to SSID2 again. BUT: whatever I tried to repeat that: I was unsuccesfull.
Eventually I killed SSID2 and it switched back to SSID1 within 50 sec’s However: it still shows “SSID2” in Profile Select

Something is not right here… With some tricks you can make it work, but it is confusing and inconsistent.

MY SUGGESTION: If “Profile select” does not allow you to select a profile NOR does it show the active profile in all cases: REMOVE THE OPTION from the UI (or make it work…)