Issue with DNS Health Check & "disconnected (WAN failed DNS test)"


#1

I have Comcast and AT&T Uverse in Florida as my two WANs. However, Comcast’s main DNS server at 75.75.75.75 is always timing out or not responding to the DNS health checks and it seems like that is causing the Peplink router to disconnect WAN1. In the “Event Log” I’ll see:

WAN: WAN1 disconnected (WAN failed DNS test)

then just a minute later:

WAN: WAN1 connected (xxx.xxx.xxx.xxx)

I don’t think Comcast Internet is down, I think their DNS server is slow to respond or doesn’t respond at all. However, I think the Peplink router thinks Comcast Internet is down so it disconnects WAN1.

How should I handle this? Should the Peplink handle DNS requests instead? I see under NETWORK > “Service Forwarding”, a checkbox labeled “Forward Outgoing DNS Requests to Local DNS Proxy”. If I enable this, will the DNS Health just check against the built-in Peplink DNS name server?

Under NETWORK > WAN > WAN1, I see the “DHCP Settings” section. I could check “Use the following DNS server address(es)” and set the DNS Servers to something like OpenDNS or Google DNS servers. Is this something I should consider?

Under NETWORK > WAN > WAN1, I see the “Health Check Settings” section, should I modify the settings here instead?

Under NETWORK > DNS Settings > I see the “DNS Server” section. If I click the question mark it says “This setting is for specifying the WAN IP addresses where the DNS server of the router should listen on.” If I go into these settings, I see both WANs listed, each having a checkbox labeled “Interface IP”. Should I modify anything here?

Under NETWORK > LAN, I see the section “DNS Proxy Settings”. Is this something I should enable.

Regardless, I need a way to prevent the Peplink from thinking WAN1 is down when it probably isn’t, but still be able to switch between WANs when it really is.

Thanks in advance for any information.


#2

I would keep using the DNS health check but change the DNS servers to Googles:
8.8.8.8
8.8.4.4

I have been using these for years and I never get any false warnings.


#3

thanks. I entered in the Google DNS. Here are some screenshots of my settings.

Would you consider these settings appropriate for my described situation?










thanks.


#4

Screenshot 1: You should adjust the Upload/Download bandwidth to the values you are actually getting from the ISP, i.e. 20 Mbps down x 2 Mbps up. Under Health Check settings, you should adjust the values back to the defaults of 5 for Timeout/Interval and 3 for the Retries.

Screenshot 2: These are your local LAN settings and you can let the Peplink be the DNS server, just check the “Assign DNS server automatically” box. You should also enable the DNS Proxy.

Screenshot 3: Looks good.

Screenshot 4: Doesn’t apply in your situation. This is if you have static IP’s and need inbound load balancing via authoritative DNS.

Screenshot 5: You should not to define any custom signal ports, your outbound rule will keep the SIP phone on WAN1.