Issue with Bonjour Forwarding on Balance 20X

Trying to get Bonjour Forwarding to work so that I can get a printer on the untagged VLAN to be visible on the VLAN 20 I have.

This is currently working at our main office which has a Balance SDX router but not at the offices with the Balance 20X routers.

Other hardware is the same; we have Peplink SD switches and AP One AX for access points.

I have it so that the VLAN 20 (WiFi) can talk to the untagged VLAN (LAN) to the IP address of the copier, but it appears that the Bonjour Forwarding is not happening and therefore a broadcast does not show the AirPrint printer on mobile devices.

I also have the issue vice versa. I want my untagged LAN to be able to find the devices on VLAN 20 so we can cast to our ChromeCast devices on the WiFi network. This is working at the location with the Balance SDX but not offices with a Balance 20X.

Within the Bonjour Forwarding Settings, I do have it to forward from untagged to VLAN 20 and then another for VLAN 20 to untagged.

Is there something else that needs to be done to have the behavior work the same?

I have a similar problem. Trying to Airprint from Guest Wifi to untagged LAN. My iphone sees the networked printer on the untagged LAN but cant print (cant connect). I have Bonjour forwarding setup bidirectionally between the two LANs as well.

UPDATE : I had inter-VLAN routing turned off on the untagged LAN. I can now print

I have a balance one…

Sadly, the “Inter-VLAN Routing” is already turned on for both.

Thinking that it may be some Internal Network Firewall rule blocking it, I removed all my rules and only adding an “Allow all;” still not seeing Bonjour from the other VLAN.

I gave up for now. I have a B20x… could not get it working. Support advised enabling IGMP snooping… tried that but to no avail.

I do have a managed switch in the mix which complicates things a little, but even Airplay device connected directly to a VLAN access port on the B20x could still not Airplay.

Would really like to get this working… and was one reason for upgrading to a Balance line of routers, coming from a Surf SOHO.

We confirmed there is a bug for Bonjour Forwarding with Balance 20X. We have filed this bug and will fix it accordingly.

Thanks for reporting this.

2 Likes

Thanks. I’ve been trying all I could figure out since the beginning of the month and since I had it working on a different router I kept comparing and couldn’t find any differences so it was making me go crazy.

I’m in exactly the same situation. I bought a Surf SOHO, learned it didn’t do Bonjour Forwarding, and then bought a Balance 20X.

I’m looking forward to the fix.

Try the 8.1.1 RC3 I’m pretty sure I saw it in the release notes.

Couldn’t get it working. I don’t know, maybe something on my end but I tried a simple setup setting a port directly on the B20x to my Airplay vlan. Hardwired an airport express used as airplay device to that port.

Didn’t work. I could see my Airplay device in the list but iPhone couldn’t connect to it when I tried to Airplay to it.

If I get chance i’ll disable my homeservers interface in the IOT VLAN and enable the mdns forwarder.

I know it didn’t work in RC2 which is why I created a Vlan interface on the homeserver in the IOT vlan so HASS could see my homekit devices.

Edit: I think it worked, Removed interface found I could still control the device (Believe it was sending unicast to it’s IP), then I changed the IP of the device (A light) and confimed I could no longer control it.

Activated bonjour forwarding and HASS was able to control it again.

Good news. I updated to 8.1.1 RC3 on one of my routers and the Bonjour broadcasting worked across VLANs.

Awesome.

3 Likes

I must be doing something wrong.

Curious is your airplay device wired or wireless?

I have only tried airplay from an iPhone to a wired Airplay device (home theatre receiver and an airport express)

So I moved appletv and airplay device, hue hub to vlan and enabled Intervlan routing. Added internal firewall rules to allow appleTv from vlan to untagged, and block all other vlan access to untagged.

This enables homekit to work properly from ios devices on untagged.

I also enabled Bonjour forwarding and lo and behold it works!

So seems intervlan routing needs to be enabled for Bonjour forwarding to work.

Sorry if this was an obvious noob mistake, but I dont recall seeing this step mentioned in the Bonjour forwarding peplink post.

Having intervlan routing enabled defeats the whole purpose of the vlan in first place, which is why internal access rules to block vlan back to untagged is required.