Ipsec vpn ovh


#1

Hi,

I’m trying to make a vpn between a peplink and a vRack at OVH provider.
Here is the guide to make a vpn to ovh.
https://www.ovh.co.uk/g1555.vpn-configuration-guide

So I have this config :
Remote host : 92.222.188.xxx
Remote network : 10.10.XX.YY
psk : XXXXX
ike : AES256 + SHA1
Group 2 et 5
lifetime :1200
ESP : AES256 + SHA1
group : none
lifetime : 3600

And I have this result :

IPsec: ovhvpn/1x1 - Malformed payload, please verify the Preshared Key or other settings.
IPsec: ovhvpn/1x1 - No acceptable response, please verify the settings.

How can we debug more to get know the problem?

Thanks,


#2

Hi,

OVH is a non-Validated IPSEC VPN device/gateway for Peplink. To further test on this, you may need to further tweak around the available IPSEC setting.

Base on the OVH user guide given:

site2site mode important notes

In most cases while configuring VPN you should set appropriate Local ID for proper mode selection.

  • Local Identifier Type : FQDN
  • Local Identifier : site2site_mode

Do you configure the local ID for Peplink ? As the info is not included for the given IPSEC configuration.

Thank You


#3

Hi,

No I tried, but I got “Invalid Local ID”. It want a FQDN with “.” in it.

I also tried using SSH and system debougmode
But I don’t get more information about the error.

Thanks


#4

Hello,

If using Main Mode you shouldn’t need to configure Local/Remote ID’s as it is typically only needed with Aggressive.

Otherwise Local/Remote ID’s of the Balance will need to be configured as follows:
NOTE Values can be changed however @ symbol is required.

Balance
Local: Peplink@OVH
Remote: OVH@Peplink

OVH
Local: OVH@Peplink
Remote: Peplink@OVH

May need to see how IPsec is configured on the Balance as well if still not connecting.


#5

hey hsauvage, did you ever get your peplink router to connect to OVH?
I am going through the EXACT same issue myself, except I’m using a Balance One.

I have tried the solutions above with no success.