iPhone Android Blackberry Issue with Captive Portal


#1

I am having LB-380 set as WLAN controller and Captive Portal (Open mode, custom landing page). Laptops are accessing Internet fine after passing login page, however there are lots of complains from Smart Phone users. Sometimes they get login page, then hangs on the redirecting … Has anybody else had any similar issues? I trying to read (using Google) in general about Smart Phone issues with Captive Portals. I see some threads has MTU issues, or OCSP/CRL issues. One thread related to iPhone was solved by bypassing authentication for apple.com (ref. http://www.mactalk.com.au/31/104047-iphone-captive-portal-wifi-authentication-solved.html). I hope I can find some guidance on this.


#2

Thanks for raising this, Mohamed. I haven’t come across this yet. I am sure we are using our latest firmware for Balance and AP One?

Feel free to chime in if anyone else has similar issue.


#3

Yes i do have the same issue but do not know the proper solution for that. It displays the login page and then starts redirecting for so long. The above post is informative and hope the problem will get solved soon.


#4

I have had the same issue PC’s and laptops have no problem but smartphone and tablet users are unable to connect. I had given up on this and disabled the captive portal due to too many complaints. The irony is that one of the reasons I chose the pepwave product was the captive portal feature.


#5

Hey guys, thank you all for your feedback. Could you please share with us which Balance and AP One firmware we are using? I can’t seem to reproduce it on the latest firmware. Thanks again.


#6

AP One 3.3.0 build 1093
Peplink Balance 380 5.4.1 build 2036

The issue occurs with smartphones and tablets and happens with both InControl on-line captive portal and the Balance 380 Ap management captive portal.

Hope this helps


#7

Thanks Dave and everyone reporting this in. We can reproduce it in our lab and we are working right on this issue.

In the mean time please upgrade to the latest Balance firmware 5.4.6 and AP One firmware 3.3.0 - the issue won’t affect Android phone on this firmware.

We will keep you guys posted on our progress here. Thanks all and sorry about the hassle.


#8

Kurt,
Great news looking forward to the solution. Good support is what makes a great product better. Many thanks


#9

Good news, guys. This issue is addressed in AP One firmware 3.3.1 which is included in Firmware Pack 1119 on Peplink WLAN Controller. Feel free to have a try :slight_smile:

Thanks again for bringing this to us.


#10

We have also come across this issue with ArubaOS 6.1.3.0 and Amigopod providing the Guest Solution. Initially I thought it was due to the SSL123 certificates we installed (which is a whole other story) but it does look to be down to something with the redirect.

Please update this thread if TAC does come back to you.