iPads losing Wifi connection on wake

I have 3 AP-One Enterprise WAPs that have been in use for 3-4 years. They are set to provide 2 different SSIDs, a guest network on 2.4 and 5 Ghz and a work network on 5ghz. Setup to use 20 mhz channels because there are a large number of nearby WAPs from other tenants. The three waps are using non-overlapping channels, WPA2/3 personal security, fast transition. Everything else is set to defaults on them.

In the last few weeks we’ve found that our ipads, which are a mixture of generations from ipad 6-8, airs 3 and 4, and some old ipad 9.7 inch pros, are now frequently having difficulty maintaining their connections. It seems that when we turn them on/wake them up they almost always lose their wi-fi connection. In fact, I’ve noticed that when you push the home button, the wifi icon shows in the upper corner by the battery, but once you enter your passcode or touch ID, it disappears. It doesn’t come back on its own. You have to go into settings and re-select the SSID

This is driving us nuts. I’ve tried resetting network settings on the ipads, i’ve erased and reset some of them up, to no avail. I’ve created a new SSID for testing, no difference.

I’m just not sure what else to try. I don’t have non-apple wifi devices that I can really use for testing, and in any case, we use the iPads because they run software that isn’t available on other platforms, so we have to get this working for the apple devices. What perplexes me is that we’ve been using this Peplink hardware for years w/o issues. No changes to the network have been made. same 48 port switches, same router etc.

Before I try WAPs from another company, I’d like to know if there is something that I’m doing with my Peplinks that doesn’t work well with apple hardware. An in particular, are there best practice recommendations for setting up Peplink WAPs for iOS?

Anecdotally and completely unverified: When the network privacy setting is enabled on the iOS device (i.e., the device gets assigned a new mac address each time it connects) we’ve had some instances similar to what you report. Not frequently enough to establish it as the cause, but when disabling the privacy mode the issue seemed to go away.

However, there were other changes in our the networks at the time, and the challenge did not rise to the level where systematic testing of the hypothesis seemed warranted.