IP Passthrough and NAT on Balance 305?


#1

Trying to wrap my head around the correct use of IP Passthrough mode on one of our WAN ports. I have created a topology diagram but here is what we have and what we are trying to accomplish:

  • Using Balance 305 HW2 as core router for a small wireless ISP
  • WAN 1 is connected to fiber. WAN 2 is on a backup cable modem link.
  • Up until recently, we did not have enough public IPs so all customers behind the Peplink were given private IPs and were NATed behind the Peplink.
  • We supply a bridge link to the customer and they have their own personal router - so the Peplink assigns the WAN IP for the customer router from the private IP pool.
  • This results in a Double NAT for each customer - they have their own internal network and then their WAN IP is a private from the Peplink. Works OK but messes up VoIP, VPNs and some other services some customers want.

Now, we switched ISPs on WAN 1 and have a /24 of public IP space as well as the /30 connection to their router from the Peplink.

What we want to do is be able to pass through IPs from that /24 to customers. We would need to manage that in the Peplink so the Peplink would still be the gateway IP for the customer (the 1st IP from that /24 pool). The /24 does not have its own gateway at the upstream ISP.

At the same time, the Peplink still needs to NAT other VLANs for us since we both don’t have enough public space for every since device and we don’t want devices on our management VLAN to have public IPs.

I’m not totally sure this is possible with a Peplink.

Basic topology: Topology.pdf (62.1 KB)


#2

For this scenario I would recommend the following steps:

  1. WAN1 has the /30 IP address to the ISP router.
  2. Peplink LAN has a public IP address on the /24 network.
  3. All routers have a public IP on the Peplink LAN pointing to the Balance for their default gateway.
  4. Use a separate router with a single public IP address to do the NAT for your other VLANs.
  5. Enable IP Forwarding on WAN1 by clicking the “?” for Routing Mode.

#3

Thanks for the help. No way to do this without the second router? Once you are in IP Forwarding on WAN 1, it is impossible to do any NAT behind that WAN?


#4

IP Forwarding WAN will not perform any NAT for inbound/outbound traffics. Your requirement is more to some traffics need to NAT and some network traffics is not. You need the second router for the NAT.