iOS downloads from App Store are painfully slow


#1

Hello,

When my iPhone or iPad are connected to the SOHO, any iOS App Store downloads are painfully slow. It takes minutes to download a 50MB app when on wifi. If I take the device off of wifi and use 4G, the download completes in seconds.

No other connections seem to be slow when connected to the SOHO. I am able to download between 1200-1900KB/sec on my computer connected via ethernet to the SOHO. If I connect my phone or tablet directly to the hotspot’s wifi, downloads are extremely fast. It is only when going through the SOHO that they are slow.

Is there any way to troubleshoot why the slowness just appears to be with iOS App Store downloads?


#2

Hi,

You are facing slow connection on App Store only when connected as below?

iPad/iPhone )))Wifi))) Surf Soho )))Wifi-WAN))) Mifi )))4G))) Internet

Every thing is ok when connected as below?

iPad/iPhone )))Wifi))) Mifi )))4G))) Internet

OR

PC –Wired–> Surf Soho )))Wifi-WAN))) Mifi )))4G))) Internet

If my understanding are correct, may I know what is the Wifi frequency (2.4Ghz or 5Ghz) below?

  • Between iPad/iPhone and Surf Soho
  • Between iPad/iPhone and Mifi

#3

Hi TK Liew,

Here is my setup that is having the slow connection. I guess worth mentioning that Instagram has a slow time loading, as well for the iDevices with this setup. I must use 2.4GHz because Chromecast does not work on 5GHz wireless:
iPad/iPhone )))2.4GHz Wifi))) Surf Soho —Tethered MiFi via USB— )))4G))) Internet

Yes, everything is fine when connected like this:
iPad/iPhone )))2.4GHz Wifi))) Mifi )))4G))) Internet
or
PC –Wired–> Surf Soho —Tethered MiFi via USB— )))4G))) Internet

Wifi frequency is as follows:

  • Between iPad/iPhone and Surf Soho: 2.4GHz
  • Between iPad/iPhone and Mifi: 2.4GHz

#4

Hi,

May I know Wifi of Surf Soho and Mifi is enabled at the same time during the problem? I just want to eliminate the interference.

May I know laptop also having same problem like iDevices (e.g. laptop, iDevices connected to Wifi at the same time)?


#5

Hi,

wifi is disabled on the mifi when it is tethered.

as I don’t use a laptop too often in my apartment, I can’t say for sure…


#6

Hi,

I suspect you having interference. Can you do changes below on Surf Soho to reduce interference? AP > Settings > Wi-Fi AP Settings

  • Channel: Auto
  • Channel Width: 20MHz
  • Output Power: Mid or Low, Disable Boost

Please adjust Output Power to cover the necessary area only.


#7

Hi,

That seems to have made a slight difference. The apps from the App Store do download a bit faster now, seemingly maxing out around 7Mbps according to the router. It should be able to be twice that speed though?


#8

Hi,

Glad to hear that you having improvement on this. Look like you having interference there (You may scan with inSSIDer). The steps I provided only help to minimize the impact. If you need to solve it, you need to use 5GHz. Anyway understand that Chromecast only supports 2.4GHz. So you have to consider the pro and cons of 2.4GHz and 5GHz.