Introducing Firmware 8.1!

We are proud to introduce Firmware 8.1. In addition to enabling SpeedFusion Cloud, this Firmware strengthens Wi-Fi security, helps you monitor your network, while adding highly requested features:

SpeedFusion Cloud

SpeedFusion Cloud: Firmware 8.1 enables the SpeedFusion Cloud. Achieve unbreakable connectivity from anywhere in the world using just a single Peplink device.

Learn More >

Upgraded Capabilities

Drop-In Mode Enabled for All Devices: Drop-In Mode is now supported by all routers. Place the router into any network environment and add new WANs without altering the configuration of other devices.

Unbreakable Time Server: Peplink routers can now serve as a local NTP server, providing connected devices with the accurate time upon start-up. Routers can get the accurate UTC from either an external NTP server or via GPS, ensuring that connected devices always receive the correct time.

Learn More >

Bandwidth Bonding Included for MediaFast 500 and 700: The MediaFast 500 and 700 now have SpeedFusion Bandwidth Bonding enabled by default, providing them with the ability to deliver unbreakable connectivity straight out of the box.

More Virtualization Options

Run KVM to Virtualize Linux Environments and More: Some MediaFast models now support KVM, allowing them to host a greater range of virtual machines including ones based on Linux.

Stronger Wireless Security

WPA3 Support: WPA3 increases your network security with additional encryption protocols and support for perfect forward secrecy. Now available on all Wi-Fi capable Peplink routers.

802.11w Support for Wi-Fi WAN: The 802.11w wireless protocol builds additional security on top of previous technologies, protecting the confidentiality of management frames as well as the data itself.

Deeper Traffic Insights

More Insight into SpeedFusion Traffic: Realtime SpeedFusion graphs display important events affecting packet flow. Each WAN-to-WAN connection has its own graph for quick and easy troubleshooting.

Upgraded DPI Report on InControl : The InControl DPI report now shows deeper information by breaking down categories (e.g. File Sharing) into sub-categories (e.g. iCloud, OneDrive, Google Drive). The report also shows DPI history.

Use Netflow to Gain Traffic Insights: Your Peplink router can now export Netflow information, which you can use to generate reports from a NetFlow analyzer of your choice. To enable this feature, please login to the Web Admin Interface as an administrator and type the following URL in your web browser:

http://”xx.xx.xx.xx”/cgi-bin/MANGA/support.cgi (where xx.xx.xx.xx is the ip address of your device).

10 Likes

Hello,

Just upgraded to 8.0.1, however I am not seeing the WPA3 Security option to upgrade my security to. Any advice? I sure hope it’s not another license thing!

Best,

Andrew

I have been using 8.1 through the betas and RCs, using it on about 50 BR1, BR1 mini and B20X. No issues, very stable. The new SF diagnostics and displays are very useful.
Several features we have been waiting for - ability to ban DHCP clients with a button click, improvements in AP controller etc
We plan to upgrade all 800+ devices later this week

What is the procedure to buy the license for Open VPN Client?

Hi Andrew,

If you update from 8.0.1 to 8.1, then the WPA3 feature should be available :wink:
You mixed the firmwares

Best wishes
Dennis

1 Like

I may be having the same issue with WPA3 not being an option. I did the upgrade to 8.1 over the weekend on 2 balance one routers. Everything went well. If I log into the router directly, it shows WPA3 as an option, but I do all my wireless settings from InControl2, which isn’t showing that as an option so I can’t set WPA3 unless I stop using InControl2 as the controller. In addition, as a side note, the router seems to have more other options as well that are missing from InControl2.

The WPA3 option will be available in the coming InControl 2.8.6. ETA: next week for Venus. Early September for Mars and Earth.

2 Likes

@BeachComber1

Suppose that should be firmware 8.1.1 feature.

1 Like

@BeachComber1 We are trying to have the OpenVPN client mode to have early access as 8.1.0 special build. Stay tuned… :crossed_fingers:

8.1.1 still be the official target.

3 Likes

Balance One, 8.1. AP/Settings.

I no longer see a New or Clone button to add additional Profiles. Have the Default and another one, but I done seem to have a way to add another. Tried in Safari/Firefox/CHrome (all current), nothing.

Am I missing something.

I have to give major thumbs up to Peplink for how well the upgrades work. I upgraded 800 devices in two days (public IC one night, private IC the next). Not one issue…of any kind. No hung devices. No failed upgrades. And the ability to schedule the upgrade with an interval (in seconds) between devices works great.
Now if only Yealink phones were as easy and smooth to upgrade…

3 Likes

Hi there,
I have updated to beta firmware 8.1before the release. Now its say my firmware is outdated and have download and update manually for current 8.1 final release. After updating and rebooting, the message is still the same and firmware did not change. Have done this multiple times. Can you advise?

2020-09-04 20_15_28-Web Admin - SURF-SOHO-EHTESHAM and 6 more pages - Personal - Microsoft​ Edge

Hi @ehtesham,

please try firmware from this post

1 Like

Is this the place to report small issues with fw 8.1?

For example, on the dashboard with pending updates, clicking the Apply Changes button does not remove the yellow stripe warning that there are pending changes. The changes get applied and the Apply Changes button gets disabled. On all other screens, it works fine, just on the Dashboard page this happens. Seems like a required refresh is not getting invoked.

Can I confirm this can be reproduced when you do some changes in support.cgi page then click Apply Changes button on Dashboard?

1 Like

Yes. I made a change on the support.cgi page, went back to the Dashboard, refreshed the Dashboard to see the pending change, hit Apply Changes button and the yellow stripe about the pending changes remained visible on the Dashboard.

@Michael234, I have checked. This web UI bug will be fixed in 8.1.1. You may need to refresh the browser for the time being.

Thanks.

1 Like

If only every bug was a trivial as this one :slight_smile: Thanks.

Another minor issue with fw 8.1:

The checkbox for enabling/disabling an AP has been removed in firmware 8.1. Beats me why. Now, to have an SSID that is defined but disabled, it has to be scheduled always off. An Always-Off AP does not appear on the Dashboard. Fine. But when viewing the list of APs (AP tab -> AP -> Wireless SSID and AP tab -> Controller Status -> Wireless SSID) there is no visual indication about an AP being “virtually disabled” (aka scheduled always off).

1 Like

Do you mind to provide a screenshot on this? I wish to ensure we are on the same page. Thanks.

1 Like