InTouch and RDP

I have a setup with a number of BR1 routers running PepVPN to a Balance router on a central location. Behind each BR1 I have a computer I am trying to connect to using RDP in the new InTouch service. Given that the network this equipment is running on is terminated in the Balance router, I figured the service would work just fine from InControl2 on the Balance router, but this seems not to be the case. When I try to open the RDP, all I get is “Permission denied - Login failed”. Anyone know the reason why? Do I need to open some sort of service on the BR1 routers?

I can use RDP from a Windows machine, running Remote Access User to the Balance router and the network in question, so I am not quite sure what is going on here.

InTouch is a web proxy service, it’s not intended for other protocols.

Its multi-protocol, or at least will be. Support for Remote Desktop, VNC, SSH, and Telnet is on the way and in partner beta at the moment.

1 Like

Oh, fascinating. I guess I’m behind on my partner news. :slight_smile:

Do you see the following screen?


If so, you are meeting an RDP authentication issue.

InTouch only supports authenticating an RDP session with a username and password configured in the InTouch profile. It does not support authenticating with your local PC’s Windows session. For security, you may leave the password field empty in the profile. Then you will be prompted to enter the password every time you start an RDP session.

1 Like

That is the screen I am getting.

I have tried everything from leaving it blank to have both user and password inserted in the InTouch profile. Still the same every time.

The issue has been resolved after we have changed some server-end settings. It was because of an authentication compatibility issue.