Internal DNS - external domain name not resolving

I’m using a Balance ONE with multiple WAN connections using a PepVPN connection.

Everything works well except for security camera configuration in home automation.

The home automation app uses - which resolves perfectly externally to the LAN

When the same app is used internally - does not resolve

I have in the local DNS records section of the Network config pointing to the LAN IP address of the Balance

Any ideas on what I’m missing please

1 Like


Reading through what you have put you say that you are pointing the internal record at the ip address of the balance. You should point the DNS record at the LAN address of the camera so that the app knows tha address of the device.

Hopefully this helps.

1 Like

Hi James

I am pointing to the balance LAN in the dns list say

What I need is requested on the LAN to resolve to (home automation server)

This works perfectly fine when outside the LAN through Port forwarding

Can you see my problem?

Thanks should point to and not

1 Like

Thanks for your help - but there is a whole bunch of devices from that domain with different ports

e.g. - home automation - camera - door station

These are all handled externally through port forwarding


DNS resolves your domain name to an IP address. Forwarding specific ports with that IP address is not a DNS function but instead it is what determines what gets mapped to your internal devices.

Using with a local DNS record would only work for a single device such as the camera. The app should work however by configuring a unique domain name for each internal device with its internal IP address.

1 Like

This worked flawlessly on a Balance 30

I can’t justify 10 domain names for each device

Their must be a better solution!



The other option would be to not set it internally and let it resolve to the external address, it should then get hairpin redirected to the correct device based on port.

I’m suprised you had this working on the balance 30 as it isn’t supposed to work that way with DNS. Do you know what firmware you were running on the balance 30 as it would be interesting to test it and see why it was working.



James - I’ve spent 12 hours+ on this and your suggestion worked immediately.

I just change the DHCP DNS Servers to Googles public ones instead of automatic and clearly it forces it out and back in to port forwarding - no more config

Thank you so much!

Glad it worked.

1 Like