Increase log debug level


#1

Is there any way to increase the verbosity of the event log? I’m trying to diagnose an issue where our Balance 210 seems to have periods where people are unable to connect to the L2TP/IPSec VPN, they just get disconnected immediately upon connecting, and the event log doesn’t show anything apart from the connect and disconnect messages.

Thanks,
Guy


#2

@knightsg

Verbose log for L2TP/IPSEC is current not available for the device event logs.

May i know what is the firmware version running for the Balance 210 ? Can you please make sure B210 running using latest firmware to isolate any old firmware issue ?

Beside that, may i know the issue happen for what devices type (Android OS, IOS or Window) ?

For Window L2TP/IPSEC Client logs, you should able to get it by referring to the URL below:
https://support.microsoft.com/en-us/help/325034/how-to-troubleshoot-a-microsoft-l2tp-ipsec-virtual-private-network-client-connection

Please open a support ticket here for Peplink support team to investigate the issue. Please make sure you provide the following items in the support ticket:

  1. B210 Diagnostic report when you detect the disconnection
  2. L2TP client logs if the device allow to export the logs.

#3

Thanks for your quick response. Our B210 currently has v7.0.0 firmware,
which it says is the latest.

We’ve seen this problem for both windows and OSX clients that connect to
the L2TP (with PSK) server. There are a few symptoms, not sure if they’re
all related:

  1. Clients attempt to connect, it says “connecting…” for a while and then
    fails with the message “The L2TP-VPN server did not respond” (OSX). This is
    after many successful connections. The configuration has not been changed
    between the last successful connection and the failure.

  2. Clients that are connected suddenly get disconnected. We have 14 remote
    user accounts but there’s never more than 2 or 3 people connected at once.
    The Peplink site indicates the B210 can support 15 simultaneous connections
    so I don’t think multiple concurrent connections are the issue, which was
    something I thought might be the case in the past.

  3. The other day I was connected fine, disconnected, then about an hour
    later tried to connect again and it would fail with the error mentioned in
    #1 above. Despite many attempts, it never worked again, even after I both
    soft and hard rebooted the peplink. I also restarted my Mac laptop
    completely. In the end, I deleted the VPN connection from OSX’s network
    connections list, and re-created it, and it magically worked fine.

I increased the debug log level on my mac and watched the log when I tried
to connect (and failed). This is what it shows:

Mon Apr 17 21:43:44 2017 : L2TP connecting to server ‘[B210 WAN 1 PUBLIC IP]’ (XXX.XXX.XXX.XXX)…
Mon Apr 17 21:43:44 2017 : IPSec connection started
Mon Apr 17 21:43:44 2017 : IPSec phase 1 client started
Mon Apr 17 21:43:54 2017 : IPSec connection failed

I’ll take a look at logging a ticket, if you have any thoughts now though
it would be helpful.

Thank you,
Guy