Https connection to my online bank slowed/stalled with dual WANs active


#1

I just got a Balance 20 and with the 2 WANS active (2 different ISPs), web access to my online bank stalls out. As soon as I set the 2nd WAN to backup, the stall clears. Is there any way around this?

For all other browsing, it seems fine with both WANS active.

I suspect a different Outbound Policy HTTPS setting will help, but I’m not sure what to try there.


#2

Please make sure a HTTPS Persistence rule (From any to any, TCP port 443, Persistence by source) is available in Outbound Policy and there are no other from any to any rules are placed above.

Also, please try to change the MTU values in WAN settings to “Auto”


#3

Okay, will give that a try.


#4

Turns out I needed to reboot the router as it was stuck somehow. After reboot, https works as normal. The https persistance rule was already in there by default.