How to setup Peplink Balance ONE to use VPN via an attached router?


#1

Hello there,

Im not sure how to setup our Peplink (192.168.1.1) for using my vpn tunnel to WAN1 attached router (192.168.0.1).
Vpn tunnel is working but i dont get any attached devices IP´s.
I have a 2nd WAN Router 192.168.4.1 attached to WAN2.

Both WAN´s are set to NAT!
I tried via STATIC ROUTE to only reach my NAS (192.168.1.100) but it didnt work - (would it work with static route? if yes how?

Would it help to setup WAN 1 (192.168.0.1) to IP FORWARDING? I wouldnt have a problem doing this because the attached router also does NAT…

Thx in advance for help


#2

No static route or IP forwarding would be required for this scenario. What is the remote LAN network on the attached router? Please provide more information about the VPN tunnel that is established.


#3

ok let me get it sorted somehow.
Before we had the peplink - there was simply 2 Routers (now attached to Peplink)
I could reach them before via VPN Tunnel and via that tunnel I could move data around on NAS System.
The thing is that since we have that Peplink I had to attach a wifi accespoint to the lan port of the Peplink so that I can connect to tne NAS system again.
It doesnt work when I connect to one of the attached routers which both do NAT.
Same is now for the VPN - My VPN tunnel is running but I dont get any access to anything

Router 1 : 192.168.0.1
Router 2 192.168.4.1
Accesspoint on PEPLINK 192.168.1.12
Peplink: 192.168.1.1 (WAN 1 192.168.0.24; WAN 2: 192.168.4.36)
Device IP on VPN Router 1 192.168.0.202

Problem with the vpn seems to be the different subnets
I dont have any clue -so I thought when i do an IP forward to Router 1 it can “see” the IP´s on the peplink and I can connect?!


#4

Where is the source PC and what network are you connecting to with the VPN? What is the IP address of the NAS system?


#5

Source PC is anywhere on the internet or on mobile device (mostly!).
NAS is 192.168.1.100.
The network im connecting to is the vpn on Router 1 => 192.168.0.1


#6

OK, now I understand what you are trying to accomplish. This should work with the following static route on Router 1: 192.168.1.0/24 next hop = 192.168.0.24 and no static route is needed in the Balance.

You are correct IP forwarding can be used for this on WAN1. Enable by clicking on the “?” by routing mode under: Network> WAN1> Connection Settings. You should then be able to reach the NAS.


#7

WOW WOW WOW!
Works now like a charm - also attached devices via WIFI on Router 1 can access NAS now AND I CAN GET rid of the wifi-ap!
THX!! you made my day!