How to route to a LAN port?


#1

Hi all! I have a router to a private network (10.x.x.x) connected to a LAN port of our PepLink 305. As all clients have the Peplink as their gateway, I want to assign the 305 an IP of that private network and create a route so all traffic to 10.x goes through that LAN port.

I have created a VLAN, assigned it an IP of that private network and enable inter VLAN routing, but it doesn’t seem to work. I’m setting the port to TRUNK. If I set it to ANY then the WAN stops working. In any case, I can never connect to my private network (which I verified works fine by connecting a PC directly to the router and using the same IP address/network mask I’m trying to set the Peplink to).

Is that scenario possible? If that’s the case what am I doing wrong?

Thanks!
pedro


#2

Do you have a network diagram to share for this scenario?


#3

Hi Ron, below is my (crude) network diagram. We have two DSL lines giving load balanced internet access to our network 192.168.1.xxx. We want to:

  • Connect a router to a private network to LAN 8 and have all traffic to 10.x.x.x go through it. The private router does NAT to the private network (can the Peplink do it?).
  • We have a semi-public WiFi network. We want those clients to access the internet, ideally without being able to see the main internal network.

Is this setup possible? I’ve created VLANs, and enabled routable VLANs, but I’m not sure if I should set the port to Trunk/Access/Any. As soon as I make any port visible on two VLANs I lose connectivity between machines on the internal network and there’s no internet access.

Thanks!


#4

Hello,

Each port on your Peplink router (i.e. LAN 8) has to be set Access on your specified VLAN (is DHCP enabled on VLAN’s?). If you have a managed switch and you want to forward VLANs then you set the Peplink LAN port as TRUNK and select desired VLANs. Also look at Inter-VLAN routing if necessarily and your router does NAT.


#5

To route traffic to the 10.x.x.x network you will need to add static routes for those networks on the Balance Core with the gateway/next hop set to the WAN IP of the private network router (10.214.257.129)

Since I’m lazy I would probably change the LAN B VLAN to be in a 192 or 172 subnet and then just have a single static route for the whole 10.0.0.0/8 block.


#6

DHCP is not enabled and there’s no managed switch. I’ll try setting them in Access for the VLAN I’m interested in. Thanks!


#7

I think I have the route created ok, but I haven’t been able to test because of the VLAN issues. Unfortunately I can’t change the IP address of the private router as it’s not ours, they provided it so we could connect to their network for some services.


#8

OK. So to summarize you need to:

  • Set the untagged lan to 192.168.1.1 enable DHCP. Now any device that connects to the balance will get an IP in that range (assuming thats what you need).
  • Set up a single VLAN for LAN B (eg VLAN 10)- set the balance IP to 10.214.257.130
  • Go to the port settings section on the Balance pick the LAN port the 3rd party router is connected to set it to ‘access’ type and only pick the VLAN you created above (VLAN 10)
  • Ask the current provider to enable IP forwarding on their router and for a list of subnets they use in the private network cloud behind it.
  • create a static route on the balance for each of the private networks behind the 3rd party router with its IP as the gateway (10.214.257.129)