How to keep external 3G connection alive

Hi, I have finally managed to get my peplink balance one core working. It rocks and is so easy to conigure… It has two WAN connected from both external routers. I am currently using NAT in both cases for convenience.

The first WAN (lets call it A) is connected to a Vodafone router. This is a DSL router with the possibility of attaching a USB 3G model. The DSL is currently unplugged and we use this router with the USB 3G modem attached. We have planned this WAN to be the backup one.

The secod WAN (B) is an aerial connection that, from time-to-time, fails and we need to transfer traffic to the A network.

The problem is that the USB 3G model disconnects from the network when it is not being used for a time so when the active WAN switches from B to A, we don’t have Internet connection. To prevent this, I decided to keep A alwasy active instead of as a backup. This has the downside of metered data consumption and we cannot afford it. So I tried to set dowload and upload speed fot this connection to 1kbps so traffic was mainly directed through B and the connection was kept alive through the periodic pings. But this happens to fail and users complain that Internet connection is terribly slow… so it seems web traffic is being diverted through A and some kind of throttle applied.

In conclusion, I cannot keed A as a backup if I want it to be kept alive… The vodafore router does not seem to have this keep-alive possibility and so I turned to the peplink balance with no luck…

The question… Is there a way to keep a connection alive while keeping it as a backup and not sending outgoing traffic through it?.

My vodafone router is model: VH4032N
My 3G router is model: K4203

By the way, I have observed that if I had the USB modem plugged into the USB connection on the peplink (which I can’t as there is a very poor connection quality inside the datacenter), there is a special checkbox under “Network->Mobile Connection” to “keep-alive” this 3G connection even when it is set as a backup connection. Wouldn’t it be great if this same option was available for the rest of WANs so scenarios like mine are taken into account?

That is my proposal, don’t know if this is thechnically possible at all…

Not sure whether i understand you correctly.


  1. USB 3G model disconnects from the network when it is not being used for a time, this cause WAN switches from B to A having issue.
  2. 3G data is expensive and can’t use as active WAN.
  3. If you connect USB modem (K4203) directly to the Balance One, poor Signals.

Do you tried before for the below settings ?

  1. Set WAN1 (A) and WAN2 (B) as active WAN for Balance One.

  2. Create priority outbound policy for the WAN fail over (Highest priority: B and backup WAN as A)

  3. Make sure “Terminate Sessions on Link Recovery” is enabled. This will make when B recover, all connection to A will be terminate and connection will initiate again using B.

-With the above setup, WAN1 (A) health will running and this will generate traffics to vodafone router and keep the USB 3G model having traffics (Health check traffics is very small, thus it won’t consume much on the 3G connection usage.
-Outboud policy will priorities all internet traffic using B, unless B is down.

Hope the above can help your case.

1 Like

Thanks a lot,

I am testing it right now. The only thing that seems different is the
“Enable” parameter. There is a checkbox on my One, but not the “Always on”
dropdown list… Is this a problem?.

That’s for enabling/disabling the Outbound Policy rule accordingly to the defined schedule. You may ignore this since schedule is not using.