Home office connection


Sorry for asking perhaps a very basic question but I need to figure out the following:

The office has a Balance One with two static iP WAN’s.
Inside the office is all Mac with a Mac OSX server that is only used on the local network.

We have a couple of people working from home and I would like to have the server show up in their “Finder” just as if they were at the office.

The data we deal with is sensitive so security very important.

If needed I can install Peplink routers in their home office.

What is the best way to go about this ?-)

Looking forward to your advice,



You can put Peplink devices at there locations and create a PepVPN tunnel to the office for a secure connection. Otherwise we also provide L2TP/IPsec as other secure VPN options.

When I connect my laptop to the network using the L2TP connection it only routes my internet traffic and not mapping the rest of the network that is attached on the other site.

Will the PepVPN tunnel make the home office connect to the office network as if its on the LAN?

If you are connecting from a Windows client, you will need to go into the settings and select “use remote gateway” to be able to talk to your LAN network. I believe MAC has the same option. Otherwise yes, with PepVPN, once connected you will be able to talk to the LAN Network as all the routes are broadcasted (via OSPF) .

Sorry no such thing in OS X other than “Back to my Mac” under iCloud.
Do you have a link to a KB article how to setup PepVPN for me?

To setup SpeedFusion/PepVPN:

Thanks for the link.
I am confused about the “How not to use the default gateway in OSX”. It starts by stating a problem that is not clear to me. And then offers a solution for Windows XP… :confused:

for OSX VPN Select your VPN connection and click on the advanced button. A new window will pop up with three check-boxes under the heading “Session options”. The last one of these check boxes is the one you want: “redirect all traffic over VPN”.

Thanks for your help, but no that isn’t showing me the LAN in the main office.
What is does is change my iP address to the internet. Witch is a good thing but not what I am looking for.

Or do I need to open up other port and set ruled in the firewall?

I suggest using Layer 2 SpeedFusion/PepVPN. You need to put a Balance router at client’s home then establish Layer 2 SpeedFusion/PepVPN between 2 sides. Below is the link for setting up Layer 2 SpeedFusion/PepVPN.


Thanks I wil try this later today!

I have followed the instructions according to the KB article.
Both Balance Once routers are on Firmware 6.3.3. build 2526.
Pep VPN version 5.0.0

I can’t get it to work both sides are stuck in “Updating Routes”

Any help is greatly appriciated.



I Read other articles in this forum. Noticed that I had the same LAN iP range on both routers.
Changed it on one end. Still no lock :mad:

Do you have multiple Vlans on either side? If so, please ensure the subnet of all Vlans is not conflict with the remote peer.

Have you configured static route (Network > Network Settings > Static Route Settings) on either side? If so, please ensure the subnet of static routes is not conflict with the remote peer.

If you don’t have multiple Vlans and static routes, please open ticket for us to check further.

Thank you.

Sorry Indint fully understand fhis


“Updating Routes” can be cause by the following:

  1. UDP 4500 is Blocked/Packet lost for some UDP 4500 traffics

  2. Multiple PepVPN connections with different Cost of the PepVPN profile defined.

  3. Subnet/network VLANs IP conflict for both network (Remote device & Local device)

  4. Others

As mention by TK Liew, if you are not sure for the issue, please open a ticket using the URL below for support team to check.


Thank You