Help -- unchecking "advertise speed" turns off LAN ports entirely?

Well, I did a stupid thing tonight…

Balance 210 router. I noticed an entry in the the log that one WAN port was going down and up sometimes at 100 mbps and sometimes at 1 Gbps. I hadn’t noticed a real world problem, only the repeated log entry.

As I was looking around the web interface, I went to the Port Setting page under LAN, and wanted to do what I thought would be a harmless test (I thought I would do a little harmless testing with a laptop to a lan port without disrupting the wan)

LAN ports were all set as access and were set to auto speed.

I changed the speed dropdown to 100 mbps and all was fine.

I then changed it to 1 Gbps and I believe I unchecked the box “advertise speed.”

Then all lan lights went off.

And I lost connection to the unit the moment I hit “apply” and cannot connect again.

In windows 10, I had my lan adapter set to auto negotiate. I changed it to 1 Gbps link speed. Still nothing when connected to the balance – ipconfig /all shows media disconnected when connected to the balance lan (works fine connected to a different switch with link speed set at 1 Gbps.)

Tried another laptop also set to 1 Gbps link speed, and still no connection to balance lan. ipconfig /all shows “media disconnected.”

The balance is not managed with incontrol and admin access is set to lan only.

How do I reconnect to it?

Is factory reset the only way?

Would it be expected that unchecking “advertise speed” would turn off all lan ports entirely?

Is there a windows setting that I should try changing to connect to the balance 210 with “advertise speed” unchecked on the balance?

The manual says “The default speed setting is Auto, which allows the Balance to detect and apply an appropriate speed setting. You can also set the speed manually, as well as specify whether the speed will be advertised on the network. Generally, advertising port speed is necessary only when the port experiences difficulty negotiating speeds with peer devices.”

I don’t understand why this turned off the lan ports entirely checking or unchecking that option.

I should also add when it was set to auto, Lan Port 1 to my computer was definitely connected at 1 Gbps speed before, as indicated by my computer, both the orange and green light on the balance port itself, and the port information screen in the web admin, so I don’t understand why changing it from Auto to 1 Gbps would cause the lan to show media disconnected now.

Has been up for 10 minutes now after pressing the reset button
[edit: I only held the reset button until the green light started blinking - this only reset the admin password. I believe to do the full factory reset requires holding the button for over 10 seconds until the light turns red (?) which I did not do.]

and still Lan is not working. To cover all bases, I’ve gone into adapter settings on a laptop and changed the link speed for the ethernet adapter from 1 Gbps to 100 mbps full duplex 100 mbps half duplex, 10 mbps full duplex, 10 mbps half duplex, back to auto, and back to 1 Gbps full duplex waiting 30 seconds between changes while running a ping -t to the balance default IP and still no LAN lights on the balance 210 and no ping response.

When I power cycle the balance 210, all port lights flash on three times (green and orange next to all).

Then all go off while main unit Status light is still red. While the status light is still red, the one lan port which I’m connected to with laptop has lights on green and orange turn on for that port. (all other ports now have no cable attached).

Then balance 210 main status light turns green and then LAN port which I’m connected to goes dark. (no lights on lan port, no connection)

Power cycled a third time and this time the lan I was connected to stayed on (green and orange for that port) after the main status light turned green again.

[post removed - not needed - delete]

[post removed - not needed - delete]

All in all an odd experience with the Balance 210 tonight. It is now working again fine but I have no idea why unchecking “advertise speed” under lan port settings would cause the Lan ports to all drop offline when clicking apply, even after 30 minutes of running and a power cycle, then with an admin password reset (I didn’t reset the unit because I didn’t hold the reset button long enough, only until the green light started blinking green), still not work after another 2 power cycles, and then start working on the 3rd power cycle on their own set to 1 gbps with advertise speed unchecked, apparently with no other visible change other than the admin password reset and repeated power cycles…

Balance 210 is hardware revision 4 with firmware 8.0.0 two months and one week old.

Has anyone experienced anything similar before with the Balance lan ports going offline after such a configuration change, and then coming back a couple hours later after several power cycles?

It hasn’t happened again. I never figured out why it happened. I’ll stay clear of touching that button until the next firmware is released :slight_smile: