Help to Connect a Canon Wireless printer to Surf Soho MK3 Firmware 8.2.1

Just got this Pepwave router and am having problems connecting this printer.
I have our 3 computers, 1 wired 2 wireless, smart TV, My Q garage system, all connected but for whatever reason this printer is a hassle.
Printer sees the SSID but refuses to connect so I can enter the wireless passphrase.
The printer shows up in AP/nearby devices as “station probe”(?) and marked as known device.


Do you have 2.4GHz and 5GHz WiFi networks set up with the same SSID and password (this is the best way to do it).

My guess is that perhaps the Canon can’t handle WPA 3 security? What security policy are you using?



Thank you soylentgreen. I had the setting at WPA3/WPA2 Personal. Yes same ID on both channels.
I switched to just WPA2 Personal and printer picked up router straight away and accepted passphrase. Test print completed successfully.
Later today I 'll switch back to first setting and see if printer will accept it now that it has a WPA2 connection.

@Chris_Bull :
Suggestion: You may also want to check for newer firmware for your printer which will support WPA3. (That was a good diagnostic step suggested by @soylentgreen .)

Failing that, if you find an incompatibility with the setting of WPA2/WPA3 I’d recommend you submit a ticket. The dev folks @ Peplink need to know. One would hope the WPA2/WPA3 setting would work.

Best not to “dumb down” the security of your network by turning of WPA3 – if it can be avoided.

I’d check the printer firmware first before entering ticket.

Great idea, Thanks Rick-DC. I just checked and the firmware is up to date on this printer with no WPA3. Why bother updating firmware to WPA3 when they can try to sell you a new one with WPA3.

That being said I switched the security back to WPA2/WPA3 and the printer tested A/OK so all is well here.

Thank you very much for your help Rick. What a great community here!

I had exactly the same problem with my Canon G4210.

I created a separate SID for the printer with WPA2 only.

Like most consumer vendors they are not responsive in debugging issues, and there is no assurance that the problem is with Canon’s wifi code, it could also be peplink’s implementation of WPA2/WPA3.

I found it to be very touchy, you could put it back in WPA2/3 mode… but after a long disconnect or reboot of the router the printer wouldn’t connect again.

FWIW (and probably not that helpful): We’ve found the Canon inkjets to be generally very finicky, including w.r.t. wi-fi connectivity. And their firmware upgrade process (whenever there is any…!) Love the print quality, but if you cannot connect….

For the Canon printers we ended with:

  • A separate SSID for them
  • Wi-Fi security set to WPA2
  • And then added a MAC address filter, with the SSID allowing access only to those that were on the list (which consisted of the Canon printers)

Worked well enough (as far as Wi-Fi connectivity and security was concerned)

Lately it’s been HP printers, with which we have been happy.



1 Like

Thanks Paul. I will follow your advise re separate SSID set to WPA2 for the printer.