GPS receiver debugging

I want to use the GPS receiver functionality to use an external GPS device on my vessel to forward its positions to the Max BR1. How can I verify if the Pepwave is receiving these positions correctly, and how can I check whether these positions are processed correctly and these are used instead of the internal GPS of the Max BR1?

1 Like

If someone has experience with this? In a packet capture on the LAN interface of the BR1 I see the NMEA strings coming in into the device correctly on UDP port 3131, including the position (GGA), sent to the LAN IP address of the BR1. GPS receiver is enabled in the BR1 configuration, UDP and port are correct. For server IP address I tried both an empty field (no access control), the IP address of the GPS unit on board transmitting the position updates, and the IP address of the BR1 itself. In all cases, I still see the wrong (previous) position on the InControl panel. In the WAN Quality report CSV download, no position information is included the whole time, in all attempts. What could be wrong? Thanks!

Also with TCP the same issue: I see a connection is being setup, the NMEA string is communicated and ACKed, but not processed…

NMEA string seems correct though:

What is the external device, what formats/connections does it support?

1 Like

Hi Jonathan,

The GNSS system is a Trimble BD982. Professional stuff that supports both UDP and TCP connections and almost any kind of NMEA output strings in both NMEA legacy as IEC61162-1:2010/NMEA 0183 V4.10, with the option to include extended information in NMEA GGA, GNS, and RMC strings.

I don’t think the problem relies somewhere in the Trimble, as I see the position updates (NMEA strings) correctly arriving on the LAN interface of the Pepwave on the right UDP or TCP port which one I was trying. Only the Pepwave is not processing them and I can’t find any documentation for debugging or NMEA string requirements.

1 Like


I just tested by disconnecting the small GPS antenna: no difference. The NMEA strings from the Trimble GPS don’t seem to be processed by the BR1.

@Giedrius can you use the same method as the starlink gps receiver to support @PeterDedecker Trimble BD982 ?

Hi Jonathan,

For Starlink it is a bit different as we communicate with terminal via gRPC API. However, for the Peter’s case, the MAX BR1, should be listening on certain port for the GPS coordinates. I will ask suppose team to jump it an comment if we support it or not with the current FW version.

@PeterDedecker could you please submit a support ticket so that our engineering team? Our engineering team needs to have a look and probably there will be additional questions as well.

I’ve created a ticket, thanks.

FYI: after creating a ticket, I was provided a custom-built firmware which reads GN prefix in NMEA strings as well as GA prefix. This works like a charm. I guess it will be included in a future firmware release. At least for me it solved the problem.