"Generic" Network Mode Unavailable

I am trying to connect my Max BR1 Mini LTE to cellular using a Visible SIM. Per recommendations elsewhere I am trying to set my network mode to “generic” but the only options I have under Dashboard->Details are Auto, AT&T/T-Mobile, and Verizon. I have the APN set to VSBLINTERNET and IP Passthrough set to on.
I have tried this under firmware versions 8.0, 8.1.0, and I’ve even tried going back to 7.1.2, but the “generic” network mode has never shown as an option.
Thanks for your suggestions.

FWIW:
Here’s what it looks like on a BR1 LTE (MAX-BR1-LTE-US) with FW 8.0.2 (details button on the dashboard)::

I don’t have a Mini at hand, but my recollection is that looks the same.

Cheers,

Z

1 Like

That’s what I expect to see, but mine doesn’t have that option there. My only options are Auto, At&t/T-mobile, and Verizon.

Hello @cartooned,
What is your routers firmware viersion? The latest release is FW 8.1.0.
Happy to Help,
Marcus :slight_smile:

Hi Marcus, my router was 8.0 out of the box, I tried upgrading to 8.1 and even downgraded to 7.1.2. The option was not present in any of the versions.
Thanks
-B

On the top question mark, is there an option to view engineering data? And if so, does it list what the modem model is? It would be something like Sierra MC7455 or Telit LM960, if we know the manufacturer and model, we can look and see if the chipset has a generic version.

1 Like

Just throwing things at the wall, here: If you go to the support.cgi page and check, is the modem firmware up-to-date?

Cheers,

Z.

PS: FWIW: The modem I had a screenshot of earlier is a Sierra MC7354, and an HD2 LTEA with FW 8.1.0 that I checked just now had a MC7455 modem, both with the generic option enabled.

1 Like

Cmetz: Here is the Engineering Data

Manufacturer Telit
Model LE910-NA V2
Firmware 20.00.005

And per the support.cgi page, the modem firmware is current

Cellular WAN Firmware version Status
Cellular Current:

20.00.505(AT&T),20.00.005(VERIZON)

Latest:

20.00.505(AT&T),20.00.005(VERIZON)|Latest firmware|

Occasionally the dashboard will say “Connected to Verizon Wireless” but more frequently it just spins on “Connecting.” When it says connected I have a usable but unstable connection, and it only works on one device at a time. Other devices can connect to the Pepwave’s WIFI but they say “no internet connection.” I wonder if this is because Visible is disallowing additional connections.

The AT&T firmware is considered the generic one for that chipset… see these release notes which can be found at http://ftp1.digi.com/support/firmware/transport/LE910NA_V2_carrier_firmware/

2 Likes

I am going through the same exact scenario and have done literally each step as the OP. I’ve tried switching to AT&T/T-Mobile since it was mentioned that for this chipset that is considered the “generic” option on this firmware with still no change.

EDIT: I took the SIM card out and put it in an android phone just to verify Visible was… visible heh and everything worked as it should so that confirmed the SIM was still active and could communicate in a phone. I then put my SIM from Google-FI in to the Max BR1 Mini and it connected to T-Mobile and everything worked as it should. (I left the settings on AT&T).

So now that I’ve confirmed hardware is good and SIM’s are good, I went ahead and powered off the Max BR1 Mini, swapped back to the Visible SIM, powered on, and it is now showing connected. Speed test is around 5Mbs and the originating IP is from Verizon.

So I would recommend each time you change a setting, even though you click “Apply and Save” I would try a reboot between each setting as well just to make sure. I guess I’ll see how long this config sticks as a working solution

This is your problem.