FusionHub on linode


#1

I found no information here about getting FusionHub running on a linode VPS, so decided to figure it out on my own. I’ve been using linode as my preferred VPS since early 2003, and always been very happy with them. I appreciate that there’s a generous amount of data included in each plan before data billing starts to occur, allowing for better budget planning. Decoding the billing for AWS and Azure is frustrating at best.

I chose to go with the Linode 2048 plan, as it includes 2TB of data transfer per month, and a VPN hub is going to be more data intensive.

The installation manual for FusionHub was somewhat helpful, and this linode document contained very useful information as well.

First, get the FusionHub installer (a .zip file) and unzip it. Then dig into it and find the .vhd file in the VHD directory, and see its size. The .vhd file is basically a raw disk image of an MBR partitioned drive.

You do not need to make the ‘installer’ disk and profile, but you do need to make the ‘boot’ disk and profile. The ‘boot’ raw disk container should be AT LEAST the size of the VHD. I made mine 410MB because I’m paranoid, and the VHD file was 400MB.

I then did the rescue boot as documented, copied the .vhd file into the booted system, then did a dd into the disk container.
# dd if=fusionhub.vhd of=/dev/sda

You should be able to run the command fdisk -l /dev/sda and see a normal looking linux MBR partition table.

At this point, shut down the rescue boot, then boot the profile you created. Connect via lish or glish, and you can run the initial setup, then connect via web browser and continue the setup, and then use it in incontrol2 just like any normal fusionhub vm.

I hope this is helpful to others.
jim


#2

Hi Jim, thanks for sharing this with the community!


#3

Hi Baadpuppy, Were you able to license the node you installed? I just installed one following your recommendations and instructions. While the installation was smooth I am unable to get the license applied. I get the following error: VMware model mismatch. Please check VMware Model and Server Address. Could this be because Linode is running on KVM?


#4

edwinm, I had no issues at all getting the license to apply. I started with the evaluation license, then once I knew it was working right, I bought a full license via 3gstore, and gave them the evaluation license information, and they did something and it changed over to match what I paid for.

fusionhub should not care about the underlying hardware (aside from meeting minimum specs) for the licensing. As far as I know, my linode is KVM based.

If you’re having licensing issues, peplink might be able to help.

Good luck,
Jim


#5

Thanks for the reply. I will contact PepLink to see if there is anything they can do. Is your install still running and stable?


#6

Yep, still running, still stable, been running since August 2018 with no real issues.

It did restart on its own one time. I don’t know why, and at the time I was too busy to dig into it, but it only happened the once so I shrugged it off.


#7

Thank you! Do you mind sharing what version you installed?


#8

It was 7.1.0, and later I upgraded to 7.1.1 via the built in methods.

Do you at least get to the control panel/web interface of the fusionhub? If you get to that point, it really isn’t any different than installing on vmware or equivalent. Everything from that point on is standard peplink.

Also, the OS partitions use encryption, so in theory they should not even boot if corrupted in some manner.


#9

Yes. The system boots up fine. I navigate to the IP with default admin admin, configure the IP and time information fine. Its only when I try to apply the license key is when I get the error. Here is the exact error:

VMware model mismatch. Please check VMware Model and Server Address.


#10

Ahh, sounds like they’re now checking with the hypervisor to see what vmware specs it has.

That’s a shame if it is a show-stopper. Perhaps they have a way to work around it though.


#11

Agreed…
FYI, the version I installed was 7.1.1 build 1538. I will try an older version. I also upgraded to 8.0 but still got the same error.


#12

Success… I was able to activate the FusionHub Installation after downgrading it to 7.1.0 build 1511. I guess there must be a check in the new versions. I will try to upgrade to the latest and report back if I find any issues.


#13

I am glad that you were able to succeed.

I’m unsure why a KVM virtualization environment gets detected as vmware by the guest, causing it to fail the checks. I tried 7.1.1 on linode and got the same results you did, but 7.1.0 activates the eval license with no issues. I also tried 7.1.1 vhd file within virtualbox, and it activated just fine. I know the virtualbox instructions say to use the vmdk file, and I tried that as well, also with success. But it also worked fine with the .vhd file. So there’s something about linode kvm mode that makes the guest think it is vmware. It appears this check started in 7.1.1 of fusionhub, so it is likely future installations won’t work on linode unless peplink looks into this and figures out why it is happening.

Not being able to get under the hood, I can’t investigate any deeper myself. I just hope it doesn’t break when upgrading to 8.x and beyond.

Hopefully someone from peplink (@Tim_S perhaps?) will weigh in here.

Jim


#14

I did upgrade the installation to 8.0 with no issues.


#15

Yep, I upgraded my eval one to 8 as well.

I was sad to see that the documentation that said “remote user access via openvpn” applies to “all models” doesn’t include fusionhub. I’m not surprised, but definitely disappointed.