Fusionhub and Verizon Fios

#1

Hey all,

I’m trying to connect Balance30 Pro to Fusionhub.
The router has 3 interfaces in use -

  1. Over fiber, Verizon FIOS - line is up and traffic is flowing but for the pepvpn - link failure, no data received and on the event log I see handshake failed
  2. Wifi as Wan - works great, tunnel is up
  3. 4G - works great, tunnel is up

What can cause the Verizon FIOS to fail the tcp handshake and how I can fix/workaround it?

Thanks a lot

#2

Port 32015 is used for handshake but some ISPs think that since its a high port number that it could be being used by torrents and block it. You could try changing it from 32015 to something lower (like 4499).

1 Like
#3

Thanks @MartinLangmaid where can I change the port on that interface on the balance? (as stated other interfaces are working great)

#4

You would change it on the FusionHub as the Balance is creating outbound VPN to the FusionHub (I assume) which would then mean that you’d update the Balance with the new handshake port to use.

On the FusionHub navigate to Network > VPN | SpeedFusion then click the blue ? icon in PepVPN Settings section and click the ‘here’ link:

You can then set a custom handshake port (for inbound connections to talk to).
image

On your balance you’d then edit the PepVPN profile to your FusionHub and click the blue ? icon next to the Remote IP Address bit then the here link:
image

You can then enter a custom handshake port in the box that appears:
image

2 Likes
#5

@MartinLangmaid Im managing the pepvpn via incontrol2.
The steps I did -

  1. Allow inbound port 4499 on the EC2 SG.
  2. In incontrol2 I edited the pepvpn profile --> selected advanced options --> set outbout port (from router to fusionhub) to 4499
  3. save config

The situation is the same - Verizon FIOS doesnt work - the other interface works

Thing to know, currently all traffic is directed to be send via fusion hub. maybe the tunnel from verizon is slower and therefore it’s trying to close the loop from the second tunnel that’s already running kind of race condition but in the end of the day only one tunnel can stay up. shouldn’t I exclude the fusionhub ips from the “send all traffic to pepvpn” ?

#6

You need to log a ticket for investigation by Peplink engineering. They can look under the hood and see what is going on.

1 Like
#7

Hi Franco,

Unfortunately, the port set under the advanced options is the data port, not the handshake port.
The handshake port is global to the device, so cannot be set in the profile.

In this case, I’d probably fallback on the firmware configuration to test if a blocked handshake port is actually your root cause.

1 Like