Force DNS Forward

I have a good number of Max BR1 units, I’m really struggling to force all DNS requests to a cloud based service I just setup. I have tried the following with no success. If a client has static settings with say Google DNS servers, I want the modem to redirect the DNS to my configured DNS servers.

Network Settings > LAN setup > configure the DHCP server to give out the wanted DNS servers.

Network Settings > DNS Proxy Settings > Enabled and setup DNS Resolvers for the wanted DNS servers.

How do I simply redirect all DNS requests to the wanted servers?

Hi Waterfarmer,

It looks like Martin answered a similar question here:Transparent DNS Proxy / DNS Hijack Solution

2 Likes

The Service Forwarding is defined as the below.

When this option is enabled, all outgoing DNS lookups will be intercepted and
redirected to the built-in DNS name server. If any LAN device is using the DNS name
servers of a WAN connection, you may want to enable this option to enhance the
DNS availability without modifying the DNS server setting of the clients. The built-in
DNS name server will distribute DNS lookups to corresponding DNS servers of all
available WAN connections. In this case, DNS service will not be interrupted, even if
any WAN connection is down.

I tried this as well, but it looks like the DNS would then be the built in DNS server on the modem. I don’t want to use the built in DNS server, I want to forward those requests to a cloud based service. I have tried multiple combinations of all the settings I can find and still nothing is working for me.

Ok, looks like I figured it out. I needed to manually assign the DNS servers I wanted in the WAN Connection Settings. This along with the other things I have tried seem to have gotten me the results I want. This shouldn’t be this confusing to setup in my opinion, but hopefully this will help someone else along the way. Thanks and have a great day!

1 Like