Firmware upgrade on a Balance One


#1

I am running firmware version 6.3.0 on a Balance One Core, there is a new firmware version available 6.3.1. When I press the “Check for firmware” button, I get a message stating there is no update available. In fact in the last few years that I have used these routers I have never been able to update firmware this way. Has anyone else been able to update this way?

The reason I am doing this is because the manual upgrade method is failing. I have a very slow connection to this router, and the manual upgrade times out before the firmware file transfer is completed.

Any input would be appreciated.

Steve


#2

Hello,

This is noted by engineering and we are re-working this feature. Assuming this is a manual upgrade being done remotely and not locally? Have you tried using InControl2 for the upgrade using firmware management?


#3

Yes, the manual upgrade is being performed remotely. I will try incontrol2

Steve


#4

I just tried this with incontol12 and firmware version 6.3.1 is not defined there either. Latest code there is 6.3.0.

Steve


#5

You will just need to choose “Custom” and use the following URL:
http://download.peplink.com/firmware/plb1/fw-b1_210hw4_310hw4_br1ent_transit_m700hw3_hd2mini_hd4-6.3.1-build2256.bin

(Just right click the firmware link to get the URL on our firmware page at peplink.com to get the URL)


#6

Ok, that worked thanks.

Why is firmware 6.3.1 code level not available in inControl. This is GA firmware right?

Steve


#7

Yes, firmware 6.3.1 is GA. The release date on the download page is the end of Feb. 2016. The feature to find new firmware on Peplink routers has never worked for me, and thats going back years.


#8

Hi,

Firmware 6.3.1 is a new released GA firmware. The 6.3.1 option will be added in InControl2 Firmware policy soon. Please stay tuned.

Thank You


#9

6.3.1 will also be made available via the “Check for firmware” button in the web admin, stay tuned… :up: