Firmware update not reflecting in control


#1

Just upgrade from v5.xxxx to most current 7xxxx on my balance 20 without any problems and current version confirmed when i check the dashboard locally. When I check on my router using in control it still lists the old firmware as the current version ???


#2

Hello Edward,

This could be a browser cache issue.
Have you tried refreshing the page or logging out and in again?


#3

If the device carries valid warranty or InControl 2 subscription, you should be able to see the device latest status, as shown below statement found in InControl 2 - FAQ.


#4

Did not help


#5

Refreshing, clearing cookies, logging out and in did not help. Was able to ping to ac1.peplink.com without any reported issue. I realized that I did not have a subscription to InControl2 so purchased online about 15 hours ago. Nonetheless InControl shows as offline and firmware reflects what was present two days ago before I upgraded firmware to 7.02


#6

I found your order and serial number and it looks like this device has never been registered on InControl2.

Can you confirm?


#10

I must have registered it as it does appear in In Control - but since firmware upgrade not updating information about it. When I login to InControl it says the device is offline; if I use the add device feature and input the serial number it says that it is already registered.

I purchased it about 5 years ago; I registered it for InControl a couple of weeks or so ago; InControl seemed to find it and report on it even though in retrospect it was out of warranty and no subscription paid for; upgraded firmware a few days ago and that’s when InControl seems to be unable to report updated information on it. Realized that I needed an InControl subscription which I purchased but InControl still not pulling updated information.


#11

Hello @Edward_Taubman,

There is a setting within the device, if the “Tick” is removed, you will not be able to “see” or manage the device from InControl. This setting can be found on the System Tab, then “InControl” on the left - as shown below.

Steve


#12

@Edward_Taubman It appears you may have registered it on the old original InControl platform and we have moved on to InControl2 quite a while ago. Please register it on the new platform:
https://incontrol2.peplink.com/

Thanks.


#13

Okay; got it working. The problem was that I had newly registered for InControl but not InControl2. InControl origonal worked until the firmware upgrade and stopped working thereafter. InControl2 required a subscription but ALSO for me to register with InControl2.


#14

Good deal :thumbsup: