Firmware 8.2.0 RC 1

We would like to announce that Firmware 8.2.0 RC 1 is now available.

Updated on 2022-Jan-22: We have just updated the 8.2.0 RC 1 firmware for BR1 Pro 5G to build 4950 that fixed the client list malfunction. If you have BR1 Pro 5G with 8.2.0 RC 1, please download and upgrade the firmware again.

Supported models:
X Series, Balance, MAX, MediaFast, FusionHub, UBR, SpeedFusion Engine, Surf SOHO

Download Release Notes
Download the Firmware


eagerly awaiting RC2 for the openvpn outbound fix. thanks

People should check their FusionHubs… about 1 day after loading B2 and RC1 the CPU went to 100%

Ticket 22010886.

1 Like

We are checking on this and we will update again.

1 Like

Wonder if its the old bug that resurfaced?

It doesn’t feel like that one… the last bug was cpu use all of the time, and only at 20%-30%. This is delayed about a day and 100%. Peplink says it is the Incontrol process, and they reset it manually and we will see if it comes back after 24 hours.

Unable to get my AT&T SIM to connect. It’s a Mobley plan, i.e. car/tablet setup. Worked fine in the BR1 Pro 5G release version, after upgrading I can’t connect and even rebooting into the prior version now it won’t connect. Works fine again in the original mobley router device. Also when getting the BR1 Pro 5G I had to manually set “broadband” for the carrier config as it was reading the AT&T 5G Sim plan (different sim I have) as t-mobile.


Would you please open a ticket for support team to have a look ?

1 Like

I’ll do that @sitloongs - my guess is it’s the sim pin feature that’s broke. This sim requires the use of a sim pin. It’s also a sim from 2017 so not sure if it’s something with older sim’s as well as I see new options for authentication, etc. that weren’t there before.

1 Like

i had this problem with my mobley plan, i had to put the APN of “broadband” in without quotes, also, there is a firmware update if you have the thales modem.

they have not changed at all, you will need the license if you want to act as a openvpn client.

Thanks @jgsieve I did try that. The sim was working fine prior to the firmware update and auto detected “broadband” but I also put it in manually and still no luck. Tried in two separate BR1 Pro 5G’s and no connection. My hunch is the sim pin feature of the new firmware may be broke.

I’m seeing strange behavior where the SIM card data at the top of the cellular screen keeps going missing for both sim slots. ICCID, MTN, IMSI, etc. Haven’t seen that before, may be an instability related. @sitloongs

the MTN is missing but no other fields, i reverted back to 8.1.3 fwiw, it took a looong time for the att to reconnect. I would suggest updating the fimware and give it 20 mins or so to connect the first time. its quick now fwiw

@NealC: As you’re likely aware, the “Mobley” plan was offered by AT&T for the express and limited purpose of connecting automobiles. Although many folks used this ultra-inexpensive plan – successfully – for other purposes (including in routers), I have to ask: Do you think AT&T may have caught up with you?

1 Like

No, I believe this is a bug in the new RC1 firmware. The prior (production) release worked fine. I put the sim back in the mobley device and it worked fine.

Reboot to the prior build and try it.


We confirmed the reported issue is related to the 8.2.0RC1 that the AT&T network mode is not well handle the AT&T connection for the BR1 Pro 5G. We have fixed that in coming firmware 8.2.0RC2 that will be released in a day or two.

1 Like

Thank you @sitloongs - per the support ticket putting the network mode to “Generic” resolves the issue and my Mobley sim connects normally again.

RC2 is posted (build 4953) - I’ll give it a try.