Firmware 8.1.1 Beta 2

Thanks @sitloongs

1 Like

Peplink is holding an “Introducing Peplink Firmware 8.1.1” webinar (US/EMEA region) on December 16th. Will we be final by then?

1 Like

It is possible, but I don’t think it will be fully GA by then. We will cover all the highlight features of whichever version of 8.1.1 is available that day :slight_smile:

1 Like

I just had my MAX Transit CAT18 reboot for the second (potentially third) time running this beta. It has been rock solid for 6+ months aboard my boat, and only started rebooting with beta 2. Anyone else seeing reboots?

I was changing the priority of a WiFi as WAN interface when it happened. Nothing in the logs other than the usual startup messages.

1 Like

Yes but on a 20x, seems to be triggered by load - Steam downloading can often trigger it.
I’ve had it reboot on 8.1.0 as well but that’s no where near as frequent.

Of course Murphys law being what it is the Balance was behaving itself perfectly when support were investigating.

I did see a Spike in CPU usage and errors on the attached USB Nic at one point, although SNMP isn’t granular enough to see if this is the cause.

Mine may be related to load, but not 100% sure. It’s happened 2x more times, and as I mentioned before, this hardware has been very reliable even through 8.1.0 betas.

1 Like


Would you able to open a ticket for this ?

I can, but unfortunately I downgraded so I could continue working reliably. I can upgrade again if there is not another beta candidate expected.

System > Reboot > Then you should see one of the two FW banks has 8.1.1 in it, just select that and reboot. You can also go back to the previous version the same way.

firmware image

1 Like

Still crashing on RC1 :frowning: , Tried another PSU at the request of support, doesn’t look to have helped.

Also as is typical when support try to reproduce the issue the thing behaves itself, anyway it’s been escalated to engineering, hopefully they’ll get to the bottom of things, got to be something about my configuration or environment that’s triggering it.

Same here 8.1.1 beta 2 is not working on my balance 20. Device is just unusable with that firmware.

Can we get the stability issues with balance 20 fixed? Cannot use 8.1.1 firmware with balance 20. As soon as I try to boot with that firmware the device gets stuck with 100% CPU and UI unresponsive. Firmware 8.1.0s083 build 4956 is working fine, so can we get the fixes from that firmware into 8.1.1 ?

Hi, I have the same problem

@Zoom and @Sergei_Shulga, please open ticket if you continue to face the problem with 8.1.1.

1 Like

I just installed 8.1.1 build 4976 on my Balance 20 and am still having problems. Here is my config:

  • two WANS
  • Speedfusion Cloud connection
  • PepVPN connection to FusionHub

I have a flaky WAN 2 connection that tends to disconnect from the internet, which causes the Balance 20 to continuously try to reconnect. When this happens, the CPU load spikes to 100% and often causes the UI to lock up. Last night, my WAN 2 connection failed and when I woke up, the UI was inaccessible (but the Balance 20 was still passing traffic). I had to cycle power in order to login to the router.

If WAN 2 fails, the Balance 20 seems to spend most of its horsepower just trying to reconnect. If I unplug the cable on WAN 2, it just says “No Cable Detected” and the CPU load stays in the normal range.

I changed the WAN health check parameters to be less aggressive and it seems to have helped with the CPU overload problem. It sometimes spikes to 100% for a second, but then goes back to normal (even if it is unable to connect). Since making the change, WAN2 has been up and down several times (technicians were here trying to fix the line) and the UI has not locked up as it has in the past.

Bad news, the UI locked up again. Not sure of the cause, I wan’t making any changes to the Balance 20. I reset a managed switch, which caused many devices on the network to go offline. When I tried to login to the Balance 20, the UI was locked up and I had to cycle the power. It took nearly 5 minutes for everything to get back to normal.

As a test, I pulled the plug on WAN 2 and the UI locked up again.

After a minute, I plugged WAN 2 back in, but I can’t login to the Balance 20. However, I think it has re-connected on WAN 2, because the router is still passing traffic and I can ping the WAN 2 IP address.

@jeff: My guess is your B20 is low on resources and this may or may not be related to the FW you are running. We’ve seen this problem a number of times. I’d recommend you (1) download a diag report shortly after you see such an issue, (2) turn on RA, (3) submit a ticket for tech support, and (4) post the ticket number here. (Shout out if you need some help vis-a-vis any of thee steps.)

1 Like

OK, I’ll have to cycle power on the B20 in order to log back in. Will the diag report still have the info you need?

Hi. Yes. Good enough. And RA will let an engineer get in and take a look “under the hood.” (Try that with a competitive brand … :wink:)

1 Like