Hello All,
Please I landed into a problem when upgrading firmware on my UBR LTE to 8.2.1. The unit has been upgraded successfully but in Incontrol2 I still see the old firmware. When I try to upgrade from incontrl2 its always pending.

Because of this my VPNs do not get established. Please what I’m I not doing right.

Is the warrenty expired, can you send a screenshot of the details on the ic2 page?
Does the UBR have internet access?
Can you ping from the pepwave?

No the warranty has not expired. I can ping IP from the pepwave UBR device.


Confirm that there are no outbound policies blocking or incontrol2.
After that try to disable,re-enable incontrol.
Go to system → InControl → Controller → change to disable , save and apply.
Go back and change Control to InControl.

If that doesn’t bring it back online try to reboot it.
If that still doesn’t resolve it, try another wan source if available.
Remove and re-add device from Incontrol2.
Beyond that open a support

Hi Jonathan_Pitts
You are an expert in this filed. It worked like magic, I spent the whole of last night trying to figure out a solution to no avail. I did followed your intuitive steps and it worked perfectly as expected.
Iam new to Peplink products. I have attached configuration I did if you would not mind kindly look through if thats the best to achieve good outcome for Facebook streaming.

May the Good Lord keep you.

Thanks for your kind words.
Ok glad that you are reconnected to ic2.
FYI the dashboard priorities are independent of the SpeedFusion priorities.
If you have two set two to P1 on the SpeedFusion profile , you don’t have to have it match on the dashboard.
The only time the dashboard effects the speedfusion profiles is when one is set to disable or if you set it alternate to the method in the speedfusion tunnels.
Generally speaking the dashboard priority is to effect default traffic not going over a tunnel.
The speedfusion profiles, and multiple tunnels look good, and indicate that you have the concept down of different treatments of data.
What do you have set for speedfusion cloud (Traffic Steering Priority , connect clients to cloud/Optimize Cloud Application) or outbound polices?
This is how you identify the traffic so that you have it go the approriate tunnel or sub-tunnel.

Thanks Jonathan,
With my UBR without static public IP Address is there a way to establish remote access VPN to be able to dial into the PBX system at the location? I want to be able to call Extension numbers from my home without Peplink device.

Several ways to deal with this.
You could have an open-vpn server or client appliance at your house
You could run a fusionhub at your house using a virtualization platform.
Does at least one side have a public routable ip address?
If not then
You could run a fusionhub at your house using a virtualization platform.
You could run a fusionhub in the cloud aws,azure,googlecloud,vultr,digitalocean with a static.
Connect house-fusion to personal-cloud-hosted-fusionhub.
Connect UBR to personal-cloud-hosted-fusionhub.
Then they interconnect to each other via the public vm in the cloud.
For mgmt http/https/ssh only you could also setup intouch.
What pbx, sip trunk provider are you using.
Our pbx sip trunks are in our datacenters behind peplink routers, if your pbx is compatible we could sell you sip trunk service and make that part of the sip trunk delivery over speedfusion easier.