Expected response time on Peplink tickets

I opened a support ticket with Peplink earlier today and it was assigned within 5 minutes, but I haven’t received a response. This isn’t a complaint - I’m just curious what the typical response time is for support tickets.

Here’s the background on my issue:
I got a MAX Transit Duo about 1 month ago and it has been working great until today. Early today, both modems went into “Resetting…” status at the same time and never came back online. The modems have SIM cards from two different carriers. After power cycling the router, the Status LED remains solid red and the router is not reachable. The cellular LEDs are not lit and the WiFi network is not broadcasting. I tried connecting directly to the router with an Ethernet cable, but still cannot connect to the admin console.

Since its not reachable there isnt much else to try except performing a factory reset. (Push a pin/paperclip into the reset button for 30sec)

1 Like

Thanks, Eric. I did try that. I held the button for 20+ seconds, and then tried again for 30+ seconds. There was no response. The Status LED remained solid red, and no other LEDs lit. I updated the Peplink ticket with this information as well. I’m still waiting for a response.

Searching around the forum here, it seems like ‘solid status led’ is indicative of device malfunction. Some suggest the 20-20-20 reset method.

You could also try powering it via USB-mini to see if the wall-power-adapter is defective.

I could be wrong, but probably this ticket would have been routed straight to the reseller based on the problem description. My guess is the response-time is typically “within 1 business day”

Thanks again for responding, Eric. The status LED on the router suddenly went green (with no action from me), and I was able to get into the admin console. All my config was still there, so the reset I attempted earlier was ignored. Both modems showed “No Device Detected”, and no other LEDs lit up. I was able to download a diagnostic report and add it to the ticket. Then I tried a reboot via the console, and I’m back to a solid red status LED and unresponsive. I’m guessing I’m looking at a warranty replacement, but we’ll see if they get back to me. I contacted the reseller separately, and they are waiting to know what I hear from Peplink.

Hi Tracy_Gullet,

Sorry for the delay in responding I was making some revisions and for some reason, I forgot to inform you about it, my mistake. However, to advance in the review it is necessary to enable remote assistance, could you help us with this step in the support, please?


1 Like

Just to close this out… After the initial delay, Peplink was very responsive on the ticket. After reviewing everything, they have authorized a return for my device.

1 Like