Enabling Mitigate Bufferbloat *and* applying the QoS options of bandwidth control and application prioritization - Surf SOHO MK3

Short version:

I’m wondering about whether it is ok to freely apply bandwidth control and application prioritization when enabling Mitigate Bufferbloat, or if there is
potential for conflicts. If no conflicts, is there simply no benefit to running all 3? ex. either enable Mitigate Bufferbloat or apply application prioritization.

Firmware 8.1.0 build 4941

On a related note:

Is the interface support page 192.168.50.1/cgi-bin/MANGA/support.cgi mentioned in the manual? I haven’t read the manual cover-to-cover, but I didn’t see anything about it. I found it only in the forums, here (comment of June 9, 2019 with screenshot:)
https://forum.peplink.com/t/need-active-queue-management-for-bufferbloat-fq-codel/16199/22

If it’s not already, this should be in user documentation somewhere.

Long version:

Before finding out it was possible enable Mitigate Bufferbloat, I tried to minimize voice & video chat lagging with just combinations of QoS options bandwidth control and application prioritization, putting the audio/video chat (ex. Skype) and streaming to high priority, and file downloads and a few others to low priority, and limiting individual bandwidth.

That seemed to help, but was definitely not a fix. Checking on dslreports, I was getting D or C for bufferbloat.

After finding out about the Mitigate Bufferbloat option, I removed all QoS options, and then dslreports returned bufferbloat scores of mostly A, some B and one C.

I got a big improvement, but it’s still not where I’m hoping I can get to. I have sometimes still been getting high loaded latency (in the high 100’s of ms, once > 1s.)

I have been playing with applying again bandwidth control and application prioritization, results still to be determined.

I can’t see a problem with having Mitigate Bufferbloat enabled while applying bandwidth control, but are there any potential problems with doing that? Or
simply no benefit to running both at the same time?

I would guess (guessing since I don’t know how the code works) that having Mitigate Bufferbloat and application prioritization active at the same time could
see conflicts, so again - any problems doing that, or simply no benefit to running both at the same time?

Further, any problems with all 3 active at the same time?

Thanks,

TKS

The most likely reasons for not maintaining a consistent bufferbloat score is that your WAN ingress and egress bandwidth settings are too high. Normally they should be somewhere between 5-15% less than the ISP provisioned speeds. However, if your neighborhood gets very busy at times, even 15% won’t be enough.

Peplink’s Mitigate Bufferbloat option currently only works for upload, not download. That can also be your problem. When running dslreports.com/speedtest, you can select “Results + Share” which will show you Bufferbloat (lag) for Idle, Downloading and Uploading. If your problem is Downloading, then Peplink can’t currently mitigate your bufferbloat situation (maybe in the next major revision though). For the record: If you have cable, DOCSIS 3.1 modems can also help uploads. They should apply DOCSIS-PIE queue management on upload (FYI, cable providers seldom apply queue management to downloads). However, Mitigate Bufferbloat’s fq_codel queue management works better than DOCSIS-PIE.

As far as using all 3 options, traffic management using DSCP tagged packets works with fq_codel (the Mitigate Bufferbloat queue management algorithm). Peplink does let you configure DSCP, so I believe the 3 options should work together but have never tried it. Someone more knowledgeable about DSCP for Peplink is welcome to comment.

1 Like

I’m going to break this down into a few replies.

I doubt bandwidth settings are the problem.

I’ve played with QoS bandwidth control. I believe this is the setting you mean, but please let me know if you mean another setting.

The ISP provisions 75 down and 10 up. When I don’t have any QoS bandwidth control set, I routinely get mid 80s down and 11 up when running various speed tests. I’ve tested with as low as 15 down and 2 up for individual users (as well as a couple of settings between that and no control) and still seen noticeable lag even at times when I doubt the neighbourhood is busy, although 15/2 might be extreme and much too low.

It is certainly possible that the neighbourhood gets busy at times, but I have no idea if it’s possible to know if you’re in the middle of a busy period, unless you can get the ISP to check at exactly that time, and with typical ISP support wait times, that doesn’t seem likely.

Have you checked to see if the WAN Health latency also surges during this time period?

My bufferbloat results so far returned from http://dslreports.com/speedtest, when D or C, scored poorly on download but acceptably at Idle and on upload.

Tonight, Sunday, around 8:30PM ET, with Mitigate Bufferbloat active:

I’ll keep digging, but maybe I’ve finally found a good selection of settings. Or maybe I just found a quiet time at home and in the neighbourhood. Tomorrow morning when more people are working or schooling from home, I’ll check again.

That’s what I have. Specifically, a Hitron CODA-4582. ISP is Rogers.

I’ve set it to bridge mode.

Edit: requoted after original edited

I will look into configuring DSCP.

Thanks, Mark9, for your response. I’ve still got some homework to do, and will respond when I have something to add, or when I can consider this closed.

codatory, I haven’t checked that yet. I will look into this. Thanks.

I didn’t recognize the acronym DSCP, and it’s not named in the UI. If I understand what you’re saying, this is what you are doing when setting options in QoS - Application.

I’ve played with a few, but at the moment have set:

  • All VOIP Protocols high, to prioritize ex. Skype, Teams, Zoom…
  • All Streaming Applications high, because the kid just got a new webcam said he wants to stream stuff. Youtube fame awaits! A new addition to my settings, so I’ll have to keep an eye on this.
  • All File Sharing / Transfer Applications low, to keep downloads slow. I noticed previously that, before doing any QoS or bufferbloat control, when the same kid was downloading games, lots of other traffic would bog down, and even logging into the Surf SOHO interface was so slow it would sometimes time out.

Lowering individual bandwidth and activating Mitigate Bufferbloat has helped hugely when kids download massive games or there’s a particularly big Windows update or reinstallation happening, but there is still work to do.

I certainly would appreciate someone with deeper knowledge of DSCP on the Surf SOHO advising.

Your Hitron CODA-4582 has an Intel Puma 6 chipset which has problems with latency and jitter. You probably want to replace it with a modem that is not based on the Puma 6. You want at least 24 channels for download to statistically give yourself the best chance for data packets to find an unused channel instead of waiting (32 is best and is the maximum for downloads). Older DOCSIS-3.0 modems don’t have PIE queue management, but that won’t be an issue if you have Mitigate Bufferbloat configured.

I assume you are setting your “Upload bandwidth” and “Download bandwidth” in WAN Connection Settings when enabling Mitigate Bufferbloat. These are the values that the fq_codel algorithm uses to manage bufferbloat on your WAN and should be 5-15% less than the ISP provisioned speeds (except managing Download is not currently enabled by Peplink, but is expected in a future release - and yes, I had to edit my original post to you above where I mistakenly said the exact opposite, that Upload was not currently implemented).

Thanks for the chipset reference, Mark9. The modem is one of the many things I have thought is possibly a problem. There are a few things a user can do to monitor its performance, but as it’s ISP-owned and the ISP has agreed to replace it, I’ll try to find out which of the models it offers now is best (or least bad, as the case may be.)

Only after that, if it still looks like a suspect, will I did deeper into monitoring it.

And this is where I have to facepalm. I found last evening that I had not set the download and upload bandwidth correctly. They were both at 1Gbps (default? some number I had set a couple of years ago before knowing better?), corrected to numbers in the ranges you stated (set 70 down 9 up vs ISP provisioned 75 down 10 up.) If needed I’ll adjust those down a bit more.

Thanks for pointing out your correction, as I missed the edit.

My bufferbloat problem has seemed to be almost entirely on download, with little (but not none) on upload or at idle, so that tells me Mitigate Bufferbloat won’t help much until Peplink adds this, if they do.

Now that I’ve set WAN upload & download to better levels, I’ve also removed QoS individual bandwidth control, however have left application prioritization. Yes, changing more than one type of setting at once will make it harder to sort out which change made the impact, but I wanted to get straight to this (correct) group of settings and give it a few days.

After that I’ll decide whether to add back QoS individual bandwidth control.

Edited original post to note firmware.

There is one other setting which you can try on the WAN side. Disable Mitigate Bufferbloat and enable QoS->Application->DSL/Cable Optimization. DSL/Cable Optimization prioritizes acks on the WAN upload side which sometimes helps Bufferbloat on asymmetric broadband where there is significantly more download bandwidth than upload bandwidth.

If it helps, you can try enabling both, but I don’t know if that works (let us know if you try).

1 Like

I have had DSL/Cable Optimization enabled since I installed this router.