Do not disable autocomplete on the login page


#1

Firmware 5.3.9 creates login pages with html like:
<form name=“login_form” method=“post” autocomplete=“off” onsubmit=“validate();”>

Please remove autocomplete=off.

Saving passwords is not a bad thing, especially when the passwords are long and different for each device.

As a workaround we now have to fallback to a Greasymonkey script to make autocomplete=“on” after the page has loaded, like:
http://userscripts.org/scripts/show/7347
and load it on these uri’s:


// @include		http://*/cgi-bin/MANGA/index.cgi
// @include		http://*/cgi-bin/MANGA/index.cgi?mode=config&option=logout&page_index=*
// @include		https://*/cgi-bin/MANGA/index.cgi
// @include		https://*/cgi-bin/MANGA/index.cgi?mode=config&option=logout&page_index=*


#2

Alright this makes sense. We will change this on the up-coming firmware 5.4. Thanks for your feedback :slight_smile: