DNS setup question


#1

Currently everything is working ok at the moment but I do notice an issue when checking the status connection of a workstation.
The DNS server is always pointing to 8.8.8.8 & 8.8.4.4 In fact if I try to setup static ip on a workstation it will not work using the router as the dns entry.

I am assuming this is because I have set the option to “Use Google DNS Server as Backup”. I just assumed that it would only be using it in case the primary went down.

I also have the option of “DNS Caching” checked. Seemed like a good idea at the time but would it be recommended to leave this off.

The DNS servers are properly entered for the 2 WAN connections. Everything is working ok at the moment so am in no big hurry to make any drastic changes.

Thanks


#2

DNS caching is disabled by default but when enabled it can help improve your DNS lookup time.

I have a feeling that we might have set in the workstation to use 8.8.8.8 & 8.8.4.4, instead of Peplink LAN gateway IP, as DNS server? This way DNS lookup will be sent to Google DNS directly instead of Peplink which can then send your lookup to where it is supposed to.


#3

Hello and thanks for the response.

Most workstations are configured to “Obtain an IP address automatically” and "Obtain DNS server address automatically"
If I do an ipconfig /all then I will see that the Gateway and DHCP are set to 192.168.1.1 (peplink)
The DNS servers will show the public dns addresses.

If I try to assign a static ip to a workstation then I have to enter “8.8.8.8 & 8.8.4.4” for DNS or it will not work.
If I try and enter the IP for the peplink 192.168.1.1 then it will not work.

There are no alternate configurations on the workstations set to use the public DNS servers.
“Assign DNS server automatically” on the router is also checked.
The ISP DNS server settings are correct as they pass the health checks and I have double and triple checked the numbers.
I cannot find either public DNS server manually configured anywhere on the workstations or router.

The only reason I could think of was the option “Use Google DNS Server as Backup”. I am afraid to uncheck it and see what happens until we at least have some scheduled maint.
This never happened until we installed the balance 20. I am not complaining, it works great! Just a little confused as to why this is happening. Any ideas would be great.
Thanks


#4

The “Use Google DNS Server as Backup” option shouldn’t matter. It only becomes effective if and only if all WAN DNS servers are unreachable.

To give us a better direction, could you please download a diagnostic report and send it to support? Downloading a diagnostic report will simply download a file from Peplink for diagnostic purposes. It will not reset/reboot Peplink or incur any downtime.


#5

OK, I have sent the report. I do not doubt that the fault is mine but I just cannot find it.

Thank you for your time! Appreciated!


#6

Thanks Eric. Your support ticket is acknowledged and our support team is in touch with you on this. We will sort this out :slight_smile:


#7

The problem was I did not have the DNS proxy enabled. After this was enabled of course the issue was resolved. Peplink support quickly resolved the issue.
Thanks for the support and taking the time!


#8

AHHH that is it. That is what we have missed.

Thanks for sharing your solution here, Eric. Enjoy you Peplink then :slight_smile: