DNS Health Failure


I am struggling with a BR1 MK2 (latest software version) and was hoping somebody might be able to make some suggestions for me please. The issue is a continuing failure of the DNS Lookup on the WAN connection. I have spent the better part of two hours trying absolutely every combination of DNS server settings I can think of, either those that are assigned by the ISP or public and I just cannot get this failure to stop. I have also tried every combination of WAN health settings with absolutely no change i.e DNS Ping , DNS Lookup & HTTP. I have also increased the health check values and times to the most ridiculously long and forgiving values and still the failures happen.

The WAN connection runs through a Ubiquiti Nano for internet access at a marina. When I connect my laptop directly to the Nano I have no issues whatsoever but when connecting it to the BR1 it becomes completely unstable. I will use the Ping and Traceroute tools and sometimes it works with 0% packet loss and other times 100% packet loss, other times it’s somewhere in between. Using trace route I can see the 2nd and 3rd devices and will try pinging them directly, pinging them on a continuing basis shows intermittent operation using my laptop connected to the LAN port on the BR1. I have checked the cables, connectors and even tested the WAN port with another system and that works fine also. So it’s something going on with the BR1 at a configuration level…I think.

I’ve read through multiple threads on the forum with similar problems but none of the solutions seemed to work for me in this case. Any other suggestions would be greatly appreciated.


What DNS servers do you have set for the WAN? This feels like a sketchy DNS server issue. Try changing the WAN DNS to google on and

I would suggest you set the WAN healthcheck to ping pointing to

1 Like

Hi Martin

Thanks for your help. The DNS servers were the ones the ISP are providing but I have tried pointing to and I have also tried other DNS providers. I have tried DNS lookup and DNS Ping pointing to and in the health check. What I find so odd is that the issue doesn’t happen when I connect my laptop directly to the nano.

Its not as odd as you might think. Your laptop doesn’t have an active healthcheck like the BR1. The reason the BR1 has a healthcheck at all is so that it can tell when something isn’t quite right with an internet link and mark it as red so another WAN link (eg 4G or wifi WAN) can be used.

For a currently unknown reason, the BR1 doesn’t think the WAN link is stable so is marking it as unhealthy and taking it down. When it does that you will have 100% packetloss until either another WAN connection is used or the wired WAN link recovers.

I suggest you disable the WAN healthcheck for the time being and see what happens. For whatever reason either the BR1 is detecting an issue with the WAN or a device upstream from the BR1 is interfering with the health check traffic.

Thank you.