Disconnected (No Cable Detected) in eventlog


#1

Hello,

We have a Peplink Balance 1350 with Firmware 5.3.6 build 1597.

My traffic keeps on getting interrupted and I have this in my eventlog:

Aug 18 08:31:02 WAN: to ISP Disconnected (No Cable Detected)

Aug 18 08:24:54 WAN: to ISP Connected (x.x.x.x)

Aug 18 08:24:41 WAN: to ISP Disconnected (No Cable Detected)

Aug 18 08:22:42 WAN: to ISP Connected (x.x.x.x)

Aug 18 08:22:29 WAN: to ISP Disconnected (No Cable Detected)

Aug 18 08:20:59 WAN: to ISP Connected (x.x.x.x)

Aug 18 08:20:47 WAN: to ISP Disconnected (No Cable Detected)

Aug 18 08:13:28 WAN: to ISP Connected (x.x.x.x)

Aug 18 08:13:16 WAN: to ISP Disconnected (No Cable Detected)

Aug 18 08:12:41 WAN: to ISP Connected (x.x.x.x)

Aug 18 08:12:28 WAN: to ISP Disconnected (No Cable Detected)

Aug 18 08:08:34 WAN: to ISP Connected (x.x.x.x)

Aug 18 08:08:21 WAN: to ISP Disconnected (No Cable Detected)

Aug 18 08:08:03 WAN: to ISP Connected (x.x.x.x)

etc…

Some days it does not happen and other days I get this. It is a 100 Mbps connection to an Ethernet modem which is working fine. How can I find out what the exact cause of the problem is ? How does the cable detection work ?

Thanks


#2

No Cable Detected means the cable is unplugged. If the modem reset, it will cause signal loss on the link and will have same behavior of unplugging cable. Regarding this issue, I suggest to check the status of the modem, it is likely the modem reset automatically.


#3

Thank you for your reply.

Unfortunately, the modem does not seem to be the problem. It has multiple ethernet ports and there is another port in use by a Linux machine which never has any connectivity problems.

From your response I understand that the “No Cable Detected” message is like the same as a “NIC Link is Down” kernel message from Linux ?

Could setting the modem and peplink ports forced on 100 Mbps Full duplex help ? Maybe auto-negation is giving a problem ? As said before, it can work fine for days and other days go up/down multiple times, very random!


#4

I’m experiencing these exact same messages on a Balance 20 firmware 5.4.9 build 1732. Only on WAN 1 which is connected to a DSL modem. WAN 2 is also on a dsl modem and does not experience any disconnects due to no cable detected. I have tried restarting the router and also the modem and have not been able to resolve it.


#5

Maybe the WAN 1 DSL modem is flaky. You should swap them around and see what happens.


#6

Hi,

Firmware 5.4.9
Peplink: 310

I am receiving the same messages. I have 3 modems in bridge mode from Comcast Business. I have 1 Netgear CG3000DCR and 2 SMC D3G-CCR. Each has a /28 CIDR block.

All network appliances on my internal and edge network run Cat 7 with gold plated RJ-45 connectors. Inside network contains a Peplink, ThinkServers, C1100 Dells, Netgear GS24t Gigabit managed switches, pure gigabit network - I also have some internal segregation using layer 3 switching and routing.

I believe the main cause of this would be the Peplink using ISP provided DNS servers as Health Report testing appliances - using Ping or 53. Some ISP’s do not allow Ping to their servers and as such the ping is discarded, Peplink notates the loss, and continues the set pattern of ping or dns query events until failure. Since it is doomed to fail, the Peplink port resets in an attempt to establish a new link with its connected line. The log notates the disconnected link as no cable detected.

The firmware should have a subroutine added:

Assign Health Status Event based on User Input or Default Health Status Event (Ping 8.8.8.8 and 4.2.2.1 or similar)
If Health Status is not changed from default then Ping Open Servers - loop. If loop ends with Health Status count =0 then reset health Status Event to secondary default Health Status Event: Reset the port, do not report the reset add 1 to #fail loop, if secondary Event is 1 then add 1 to #good and loop until the line breaks again or is changed by user: simple DNS query to some open servers or whatever uses layer 3 although a Layer 2 test following after failures may be of interest, especially if the test turns out to be good. At least you have an idea that maybe you fell off the routing table near the Tap or Demarc even the last mile provided you follow that Good Layer 2 test with a trace.

It’s just a theory. I know very little about nothing. I hope I didn’t appear very clumsy here. I just think that perhaps besides dismissing the issues as ISP related - step outside the box and find out the very obvious question we are all asking:

When does teh firmware reset the WAN ports during operation and what are the routines? (E.g. The WAN ports will reset if A is met, B is met AND C. The Peplink resets the port in an attempt TO ESTABLISH (a handshake, a response, a date for the prom)

I know we all aren’t speaking Pig Latin here and some insight would better allow us to thoroughly investigate the issue starting with Layer 1 of the OSi all the way up to 7. At least, that’s what I was taught by the Department of Defense, Cisco, IBM etc…

lastly, this may be harsh words falling on an awestruck crowd thinking the forum nor its participants deserve such words. I disagree. Not once was the real question answered - instead the same low brow, mindless and offensive reply (offensive to the people who pay well over 1500 an appliance and don’t even get Peplink.com support NOR can they even buy their way in - that is an irritation in of itself)

So, please. Do us a solid. Answer the questions like a network engineer, programmer or technician and not as if we are all morons and that the bane of your existence is yet another modem from the evil ISP empire whose goal, it appears, is to toy with your Peplink ports.

If anyone would like to respond about how this post is sideways or rude; please, don’t - it just adds to the question I now have about Peplink Support and the quality of service they provide. Ill reserve judgement for now, at least a vocal one.

Man, might as well told the guys to go yank the router off the rack and ship it back because they’re stupid.

Here’s you buck bad, dude. Stop passing it around and step up to the challenge or stop making routers and stop wasting our time waiting for a poorly written, uneducated response. Go look it up. Its your equipment. Its not us.

Dude, ask at least a couple questions before you put us to bed. Fake it.

Fix yourself or I will make this a very public note - Peplink Support: Go read the manual and call your ISP if you have an issue. Peplink: Above Reproach. Your Fault.

Cheers and Semper Fi

EDIT:

I solved my issue by enable DNS Lookup Using Host 1 and Host 2 8.8.8.8 and 4.2.2.1 (not my ISP servers becuase they respond to no ping, nada) Uncheck the next box labled “Use the first two DNS…” and the next box is checked “Include public DNS”


#7

Hi Eric-

I’m glad you got it working, thanks for the update. We do offer three different health check methods to suit different environments; DNS, Ping, and HTTP. Default out of the box uses DNS with the ISP’s servers and we have found that this works just fine for 90%+ of worldwide customers, so we use it as the default.

I did point the customer towards a possible bad modem or bad WAN1 port on the Peplink. I suggested to swap the modems between WAN1 & WAN2 to see if the problem followed the modem or stayed with the WAN1 port. I feel this is a quick easy way to determine the next step of troubleshooting. I wasn’t jumping to conclusions trying to blame anyone, it just seemed like a logical approach to the situation the customer was experiencing.

Unfortunately, our support team members spend the majority of their time troubleshooting non-Peplink related issues. In these budget restrained times, we find that there are a lot of people who get tasked with being the IT person that should have no business getting even close to a router, let alone managing a network. We end up having to teach these people basic networking. It can be frustrating and time consuming, but it goes with the territory. We treat these customers with the same amount of respect as we would with a very knowledgeable person such as yourself. Only about 1 out of 30 support cases actually need escalation to the development or engineering teams. All I am saying here is that we need to try and be as resourceful as possible, and pointing towards a possible bad modem or WAN1 port is a realistic next best step to take in my opinion. I can understand and respect that you may disagree.

If you ever need our direct support, please feel free to call us toll free at 866-463-0129 between the hours of 9AM-6PM CST. If you are out of the country you can call +1 650-450-9668. If we do not answer it live it means all team members are on the phone, but our average response time to messages is under 20 minutes. You will speak with a courteous, professional English speaking person located right here in beautiful Minnesota, USA. If you did purchase from a reseller, we may ask if you have contacted them for initial troubleshooting, as this is something we expect of our partners. However, the fact of the matter is that we will never deny you or anyone else that needs our direct support, this I guarantee.

Your post actually surprised me quite a bit. I can count on one hand the number of poor customer support experiences I have seen over the last 5 years. Most customers praise us for our support and are thankful to talk to a real live human being instead of a machine or third-world call center. I understand you are not happy with our support, and for this I apologize.

Lastly, I want to thank you for your support of our brand and solution. We genuinely appreciate your business!

Best regards,
Tim