Disabling Reply to ICMP Ping does not work


#1

Hi.

I have a Balance One running 7.0.0 Build 2742. I have Reply to ICMP Ping disabled, but the router is still replying to pings. I have tried rebooting the Balance One, but this did not help.

Has anyone else seen this?

Regards

Steve


#2

I have tested the exact same firmware (7.0.0 build 2742) on our lab unit (Balance One Core) with [Reply to ICMP Ping] unchecked, I tried to Ping the WAN 2 IP from external side and it returns “Request timed out.”, which is an expected result.

You will get Ping reply if the Ping request coming from LAN (internal) side, as this option meant to be applied on Ping request initiated from external side.

Where do you initiate the Ping request from?


#3

I am pinging from an external host on the WAN side, not the LAN side. I have also tried pinging from websites with ping tools, and mobile devices with wifi turned off.

As a test, I shutdown the router, to prove that the pings were not being returned. Then restarted the router, and the pings began to be replied.

I will do some more testing.

Cheers

Steve


#4

In addition uptimerobot.com is seeing this router as UP using ping.

So I am pretty sure now that it is responding to pings from external hosts.

Steve


#5

This behavior is inconsistent with our lab test results. Please keep us updated to the results of your testing and problem isolation efforts. If you would like support from Peplink to help diagnose why this is occurring please open a support ticket here.

Thank you.


#6

I ran into that issue awhile back. I posted the solution here:

https://forum.peplink.com/t/wan-connections-are-replying-to-ping-when-they-shouldnt?source_topic_id=8033

#7

Thank you for sharing your solution and guiding others searching for one to your post.
That is very helpful and appreciated.


#8

Thanks for posting this LordFlux.

I have opened a ticket with Peplink on this as I think this should be more understood and doing a complete restore is a workaround in my opinion (that is not intended as an insult), but Peplink needs to investigate this.

Regards

Steve


#9

I received a reply from Peplink support on this issue and they were able to reproduce the problem.

They stated it would be fixed in release 7.0.1.

“In the meantime, there is a work around which requires ICMP ping to be enabled on WAN6 which will then cause the disabled ICMP ping to work correctly on WAN1”

I tested this, and it worked. Note, in my case WAN6 was not in use and disabled. But enabling ICMP ping on WAN6 fixed WAN1.

Cheers

Steve