Difficulty forwarding ports for Home Assistant

Hi folks!

My setup is a little bit messy so please bear with me for a quick bit of background.

I have an HFC modem supplied by the NBN (Australia’s broadband supplier). It doesn’t have any config options at all, it just handles the internet connection. This is connected to an ISP supplied TP-Link modem which handles ISP auth, VLAN tagging and god knows what else. I’m meant to keep these first two elements as part of my network. The modem is then connected to the WAN port on my Google WiFi; this is the network I want / that all of my devices actually connect to. The LAN port of the Google WiFI goes to a Netgear switch which is also connected to various wired clients in my house. Everything here lives in the 192.168.0.* namespace. I can navigate to 192.168.0.1 to get to the Google WiFi admin page, and 192.168.1.1 to get the TP-Link’s admin page.

One of my wired clients is a server running Plex and Home Assistant. I acces Home Assistant via DynDNS + an HTTPS URL.To make this work, the Google Wifi (192.168.0.1) sits in the DMZ of the TP-Link modem (192.168.1.1). The Google Wifi then forwards port 443 (HTTPS traffic) to 192.168.0.3:8123 (the server + HA’s port). This all works reliably.

Because Australia’s broadband is so awful, I recently picked up a Huawei CPE 5G Modem. This is more reliable but much more expensive. I’ve added a Peplink Balance 20 to my network; it prefers WAN 1 (the TP-Link modem) but will happily fail over to WAN 2 (the Huawei 5G modem) as needed. The only client on this network is the Google Wifi Router. I can still navigate to all my 192.168.0.* clients, including the router itself at 192.168.0.1. When I navigate to 192.168.1.1 I can view my Peplink config. I can’t access the TP-Link config page anymore (it used to be at that address) but I’m not too bothered by this.

Almost everything is working as intented now - if the broadband goes offline, the 5G takes over and Netflix keeps playing, my security cameras keep streaming etc. Plex works fine. Home Assistant, however, is no longer accessible via the public URL (ERR_CONNECTION_TIMED_OUT). I suspect the traffic is getting stuck somewhere on the way.

Things I’ve tried:

“Drop in mode” doesn’t exist in my network settings - perhaps because I have a preference setup for the two WANs?

Forwarding the Interface IP for all WANs on TCP:443 to both 192.168.0.1 (the end target), 192.168.1.1 (the Google router) and 192.168.1.11 (the DHCP address the Peplink has assigned to the Google router). None work.

Enabling UPnP and NAT-PMP - no changes.

Adding a NAT mapping for LAN client 192.168.0.1; inbound from WAN 1 and WAN 2 interface IP.

I know very little about networking (as you can probably tell). Could anybody help me out with a suggestion of what to try next?

Hi,

Did you contact the partner who sold you the Balance 20?

You can also send us your details to: support@advantesco.co.nz and our NOC team will have a look.

Cheers
Mandy