DHCP Relay not working


#1

On one of my Balance 710 I need DHCP relay but I can’t get it to work.

I have a VLAN10 where a Windows Server DHCP server is located and a VLAN11 without DHCP server. On the Balance 710 I configured on VLAN11 the DHCP Relay pointing at the DHCP server on VLAN10 and the Microsoft DHCP server has a scoop configured for the subnet on VLAN11. If I setup a client on VLAN11 with a static IP I can ping the DHCP server (and everything else on VLAN10) but I am unable to receive an IP address from the DHCP server. It times out with an error that is cannot contact a DHCP server.

The whole setup seems very straight forward but what am I missing?

//Marco


#2

Hi Macro,

I tested it was working fine. Below is my settings on Balance router with v6.3.1.




I am using Microsoft DHCP server in Vlan 53 with IP 192.168.53.18. Client in Vlan 51 can grab IP 192.168.51.10 finally.


  1. Which Balance’s firmware version you are using?

  2. What DHCP server you are using?


#3

It looks exactly the same in our configuration besides the IP addresses and the VLAN ids.

  1. firware version 6.3.1
  2. Microsoft Server 2008 R2

We are trying to find out more with wireshark.

//Marco


#4

Is it possible that Balance 710 Hardware revision 2 isn’t compatible? It looks like the DHCP packages from VLAN11 are not coming through the Peplink Balance.


#5

Hi Marco,

I come across with the issue below by using Microsoft DHCP server.

  1. I am running Microsoft DHCP server in VM. So, it was grabbing DHCP address from Balance router’s Vlan 53 (server farm). I am lazy to set static IP on Microsoft DHCP server since it was just for testing purpose. :stuck_out_tongue:

  2. Then I realize client in Vlan 53 (server farm) can grab IP but this not happened in Vlan 51 (Client).

  3. Then I disable DHCP server on Vlan 53 of Balance router and configure static IP on Microsoft DHCP server. Dramatically, client in Vlan 51 (Client) managed to grab IP from Microsoft DHCP server!

Not sure whether you are having the same situation with me. If so, this is a good reference for you.


#6

Our Microsoft DHCP server is also running as a VM but has a static IP address.
I have found another technician to analys WireShark.


#7

I tried the same at another location but same result. This is a balance 580 HW rev 1 with fw 6.3.1

In this case VLAN10 has the (Microsoft) DHCP server


VLAN50 has a relay to the DHCP server on VLAN10


On the DHCP server there is a scope for subnet 10.69.240.0/24

With a static IP on the client on VLAN50 I can reach VLAN10 whithout problem

But changing the Client to DHCP, it never receives an IP address from the DHCP server

We ran WireShark on the DHCP server but we can’t see any DHCPDISCOVER broadcast on VLAN10 that comes from VLAN50.
So, it really looks like the Balance is not forwarding the DHCPDISCOVER package to the DHCP server.

//Marco


#8

Hi Macro,

Have you disabled DHCP server on Vlan 10 of Balance router?

The different between us is the Microsoft DHCP server. I am using Microsoft Server 2003 64bit.

Fyi, we changed the broadcast to unicast for DHCP request over layer 3. Broadcast traffic cannot go through layer 3.

Please perform following steps and send us the Pcap via ticket.

  1. Login to Balance router

  2. Enter HTTP://<LAN IP of Balance router>/cgi-bin/MANGA/support.cgi

  3. Navigate to Network Capture > Start. Recommend to do this at Non-peak hours. Our device do have the limited buffer.

  4. Simulate the problem (grab IP from Vlan 50).

  5. Navigate to Network Capture > Stop > Download.

  6. Please provide steps no.4 tested destination IP addresses (Microsoft DHCP server) for the captured logs analysis.

Thank you.


#9

Sure the DHCP server in VLAN 10 is not enabled


I opened a ticket and attached the network capture.

//Marco


#10

Just to check that the DHCP server is working I took away the DHCP relay from the balance and added a Cisco router in the network with an ip helper-address 10.69.199.17 on VLAN50. Then I was able to grab an IP address.



#11

Hi Macro,

I tested Microsoft Server 2008 with positive result. Please submit the Network Capture. We need to check further.

Thank you.


#12

I attached the network capture with the ticket #761163