DHCP DSL Modem configuration


#1

I have installed a peplink balance 210 for Internet redundancy. I have configured the WAN 1 port with a Static IP address from a cable provider. It is working properly. WAN 2 is a DSL connection using a Zyxel 660 modem. The connection is provided by DHCP. The modem is in bridge mode in order to pass through the IP address to the peplink, but I cannot get an external IP address on the peplink. I only get the LAN IP address of the DSL modem, and then only if DHCP is enabled on the LAN side of the DSL modem. I think the problem is related to double NATting that is going on, but I’m not sure how to work around it. I looked at the guide for drop-in mode, but that does not appear to be the configuration I’m dealing with. Any suggestions? Thanks in advance.

Steve


#2

Zyxel 660 modem… PLDT ? You may need to set the MAC address in your Peplink WAN 2, to that of the DSL modem.


#3

Steve, If your DSL modem is operating in bridge mode, then I think you need to configure the WAN on Peplink to PPPoE which needs to enter the PPPoE username and password.

You can try to use a PC to try to see how to connect to that Internet first, may be you can ask your ISP to confirm the connection type.


#4

Not sure what you mean by PLDT? Where do I set the MAC address? Thanks


#5

This is not a PPoE connection, no username/pw. We had a cisco/linksys small business router that worked fine. Bridge mode passed the IP address from the modem through to the wan side of the router. Peplink doesn’t do this.


#6

Steve, what happens if you hook a PC up directly to the DSL modem?


#7

Thanks for the response. If the pc is set for dhcp, I get the WAN address of the modem, 71.xxx.xxx.xxx. Which, as I understand it, indicates bridge mode is functioning properly.


#8

And it should work the exact same way with the Peplink, although 99% of the time the PPPoE authentication is done on the Balance.
Please double check your WAN settings and also check with your ISP on how authentication is done.


#9

Thanks, I’ve checked multiple times without success. Also, as stated above, this is not a PPoE connection; it’s always on, no authentication required.


#10

I have an ISP DSL that delivers without PPPoE as well. For my model 30, I set DHCP and away it goes. Static IP should work too, if assigned. The duplicating the modem MAC was needed to emulate the original CPE modem from the ISP - they limit what connects to their system. Usually a label on the modem bottom with this, or in the config somewhere.

In the original modem (that same Zyxel 660) the connection type was listed as EthEncap. The best I can tell, its the 802.3 encapsulation.