DHCP Broadcast Flag


#1

Hello,

I have cable modem service from Charter communications. My issue has to do with the way Charter handles DHCP between the Peplink router and the cable modem. My issue is NOT with the Peplink 20 in any way, but I am hoping for a workaround…

Charter resets the cable modem frequently. Sometimes (four times so far this week) the router is unable to get an IP address from the cable modem after a reset. My old Linksys router running Tomato had the same problem, but not as often (once or twice a month).

If I hook up my laptop, I get an IP address from the cable modem instantly. I researched it, and it appears that Windows sets the DHCP Broadcast flag by default, but most routers do not.

Is there any way that I can set the Peplink to enable this flag?

Random information:

  • Apparently, at a command line it would be “dhcpcd -B eth0”

  • According to the OpenWRT documentation this will “Enable the broadcast flag in DHCP requests, required for certain ISPs, e.g. Charter with DOCSIS 3”

Thank you for your time…

P.S. the Peplink 20 is running perfectly and the DSL line is keeping me up and running!! Thanks again!


#2

I have the same problem with a Charter modem. On april 4 2014 the balance 20 could not get internet access. I swapped it for a dlink router. next day the balance 20 connected just fine. Again tonight, (04/17/14) the balance 20 would not connect to the internet. I shut both the modem and router down for 5 minutes… then tried again, nothing. My laptop connected immediately using the cable connected to the Charter modem. No modem reboot. My PC would not connect. I am typing this on the laptop connected to the Motorola Docis 3.0.


#3

Sorry to hear about your issues… I finally gave up and had Charter replace my personally owned Motorola cable modem with a Chartered owned Cisco modem.

Even though the fix was outlined in my first post, this is (understandably) a very low priority for Peplink.

If your local Charter has Cisco modems available, try one. The Balance 20 has worked perfectly since then.

Good luck!


#4

Thanks for the update. Charter recently bought Optimum last year. And Optimum bought Bresnan cable services 2 years ago. So I have been through 3 cable suppliers in 3 years. Both Bresnan and Optimum allowed up to four IP numbers per account. About 3 months ago, everyone in Western Colorado was switched over to Charter’s equipment and software. That’s when my problems started.

I tried logging on again at 12:30 am with no luck. At 5:30am it finally re-connected. So, unlike others reporting the problem taking 3 minutes to resolve, here it is more like 5 hours until the blacklist is cleared.

The reason for the history and (very) long explanation is for any other user who beats their brains out trying to solve this problem. I am very grateful you documented your problem and am glad the fix is just to swap out the modem.

The cable service is so bad here in the Grand Junction area I would rather visit my dentist than call the cable company. I own a small Mobile Home Park and provide WiFi to my neighbors…free. You can not imagine how mad they get when their FREE service is down. So my final question. Which model of the Cisco cable modem do you use. (i would like to buy it myself and call Charter with the new MAC address).

Again, thanks for your help.
Patrick


#5

Patrick -

I have a Cisco DCP-3008, but the DCP-3010 is also supported by Charter and “fixes” this issue as well…

I really understand your frustration with Charter… they are why I bought the Balance 20 in the first place. I also have ATT DSL …

**Don’t buy the modem… my understanding is that Charter does not allow the customer to use their own modems anymore , although customer owned modems that were in place prior to this policy are grandfathered in. **

My advice is to take a deep breath and find out what cable modems are supported in your area. Call the local Charter location directly, and if that is not possible, go to the Charter location. If the Cisco modems are supported, then see if you can pick one up at the store and have them change the MAC address right there, or have them do a truck roll and have the tech do it. The techs in my area were very helpful, although they were skeptical that the new modem would help… as soon as they swapped it out, and update the MAC address on my account all was good. I never got blacklisted again.


#6

Thank you again,

All monopolies suck. I HATE the ones I have to deal with. We have Charter for cable, Xcel for utilities and Century Link for landlines. I use DirecTV (DISH competes) I’m stuck with xcel for electricity (but not forever, solar is coming to my house soon) and we use Cell phones, where the competition dropped my bill from $345 a month to $144 a month in January 2014. We have the same 5 lines and now unlimited everything (there is no 4g anywhere in my part of Colorado so unlimited 3g is ok) And we went with T-Mobile as soon as my Verizon contract ran out. Out here in the sparsely populated western Colorado, all 5 mobile providers share the same towers so all the service sucks equally. I use wifi for most calls anyway.

OK, enough rant. Thanks a million for the good advice. I will follow up Monday at the Charter office and see if I can get a new modem.

I also went ahead and filed a support ticket with PEPLINK. It can’t hurt and I will admit, the reason I went PEPLINK over other bonding routers, was the great customer service described at “Small Net Builder”.

I will add a DSL line to my Peplink 20 very soon. I was hoping to work out all the bugs before adding another provider. That strategy might of shot me in my own foot, as it wasted a LOT of my time troubleshooting modems, routers, IP#'s and related software.

Anyway, you have been a real help.

Thanks.

Patrick