DHCP address issue


#1

Hello everyone,

Something strange has happened - I have a balance one core as the main router in a WISP network.

I installed a OpenMesh Cloud Managed switch 4 months ago and the router handed it out a DHCP address. Then 15 days ago the devices disappeared from the network and would not get a DHCP address again. I checked with my laptop and the router was still handing out a DHCP address to my laptop.

I thought It was a switch fault so got a replacement OpenMesh switch and plugged it all in and again the peplink router would not serve it a DHCP address. I tested both switches on a different network with a non peplink router and they worked no problem. I tried adding the switch as a DHCP reservation but that didn’t help either.

It would appear that the peplink router could not see the switch and/or would not give it a DHCP address. There has been no network changes - the only change was a router firmware upgrade 10 days prior to the switch no longer working.

Any ideas why the Peplink router has decided to stop speaking to OpenMesh devices?

Many Thanks

Cameron


#2

Have you tried a different cable? Different port on the Peplink perhaps? Network interfaces can go bad :slightly_frowning_face: And it is never a convenient time when it does.

You can do a packet capture to see if the broadcast dhcp requests make it to the router.


#3

Yup tried several cables and ports.

How would I do the packet capture?


#4

I haven’t found a good way to do it in a mac, but here are some instructions for PC.


#5

We have experienced DHCP leasing issues with peplink. The it does not release DHCP leases/ clean out old mac arps well. We opened a case with peplink support, however they claimed it was due to the subnet being a /22 which was incorrect.

Hoping they can get to the bottom of this


#6

Can you share the ticket number?