Device Hang when establish IPSec between two balance

My client have one Balance 580 in HQ(with total 1gbps Bandwidth) and one Balance 20 in branch(with 200Mbps total bandwidth), the issues is when they try to establish ipsec vpn between these two balance, the balance 20 will hang and need to force restart, any idea on this? Is it the bandwidth issues or? Appreciate your guide

Hello @yschang7520,
Welcome to the Peplink Community Forum.

A few things to check:

  • What version of FW are they each on? Check to see if you are running 8.0.2 as a minimum.
  • Look at using PepVPN/SpeedFusion in place of IPSec between Peplink devices.
  • Add the devices into InControl2 so you can get longer-term details on trends with your devices.

Happy to Help,
Marcus :slight_smile:

1 Like

Hi. May I add one thought to @mldowling’s good advice? We would normally use PepVPN or SpeedFusion between two Peplink routers rather than IPsec. I’m wondering if you’ve considered/tried that? - Rick

1 Like

Have tested with pepvpn, same result, CPU usage in balance 20 will spike until 100% after turn on vpn

The Balance 20 is probably a bit marginal for its intended use. Your needs may be better served by a router which has a bit more “horsepower” and can fully service your 200Mb/sec WAN. Perhaps more importantly, there is a real limitation re PepVPN throughput. The 20 can handle 30 Mb/sec while the 580 can do 200. Something like the One, Two or 20X may be a better fit.

1 Like

Having the same opinion tho, will suggest client to upgrade