Custom service forwarding


#1

I am trying to get my Balance 30 to use a content filter.

I have a Diladele content filter setup on a virtual pc. When I manually point my browser to the filter everything works correctly but when I use the Custom Service Forwarding Setup the filter only sees the URL without the host.

Has anyone had any success getting the Balance to use a proxy and if so, how did you do it?

Thanks


#2

I’ve got my Balance at home set to use the Custom Service Forwarding. I’m pointing port 80 traffic to the server address and port on my LAN. Its not a virtual PC though, its dedicated to this task. Lubuntu Linux running Squid as a proxy and caching server.

I don’t have any experience doing this with a virtual PC but hopefully this helps at least validate that the feature works.


#3

Thanks for replying,

That is what i tired to do, but when i go to (for example) “http://www.msn.com/?ocid=iehp&pc=EUPP_” my proxy returns the following.

for some reason the host part “http://www.msn.com/” is missing.


#4

I think the issue is your squid.conf may not be setup to be transparent. The browser doesn’t know its going through a proxy when you use the Custom Service Forwarding option, vs the traditional approach of putting proxy information into a browser. I’m assuming if you did that everything would work fine.

“http_port 3128 transparent” should be set in your squid.conf or you can change the default port to 80, either of those options should work for you.

Best of luck!


#5

Thanks,

Changing the squid.conf to “http_port 3128 transparent” gave my browser an connection error, but you have given me a place to start.